VectorLinux
April 24, 2014, 09:36:31 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Rosegarden for VL standard 5.8  (Read 7405 times)
V3ct0r
Member
*
Posts: 19


« on: June 19, 2007, 03:03:32 pm »

Hello, I have VL std 5.8 on my laptop, and I wanted to have Rosegarden installed, so I found this file

rosegarden-1.4.0.tar.bz2

But I dont know how to install it: installpkg doesnt work with .bz2 files, andwhen I extract the .bz2 file it gives an error and makes a folder full of stuff i have no idea what is for...

Do anyone know how I should proceed to install rosegarden-1.4.0.tar.bz2 in my computer?

Thanks
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #1 on: June 19, 2007, 03:36:41 pm »

Hi! There is a rosegarden package in the testing repo, so you can install it vis Gslapt. You need to add the testing repo -and probably you want to have the extra repo too- to your /etc/slapt-get/slapt-getrc. Edit that file as root and add this:

SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/extra/
SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/testing/

Save the changes, then you can open Gslapt, click the Update button and then rosegarden and other programms will be avaible to install for you.
You can use the slapt-get command on a terminal too, is the same.

btw, that file you have there is the source code, the standard process to compile sources is a)uncompress it to a temp dir, b)from that dir on the command line, type ./configure, you need to check the output of that command and solve any dependencie issue; then make, and then as root make install. You want to do this if there is no packages for you in the repo, or if for any reason you need to compile it with differents ./configure options.

Hope this help.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #2 on: June 19, 2007, 03:39:45 pm »

It looks like you probably downloaded the source code for rosegarden.
You could try to compile it, but thats not necessary since there is a rosegarden package in the VL testing repository.

Run this command as root in your terminal to add the testing repository to slapt-get:

Code:
echo "SOURCE=ftp://ftp-osl.osuosl.org/pub/vectorlinux/veclinux-5.8/testing/" >> /etc/slapt-get/slapt-getrc

Then run GSlapt and hit the "Update" button to refresh the package list, and then run a search for "rosegarden" (without the quotes).
It should appear in the list and you can then install it.
Logged

V3ct0r
Member
*
Posts: 19


« Reply #3 on: June 19, 2007, 04:02:01 pm »

Thanks for answering =) but how do I "open Gslapt"? see, little things like that allways get me lost, if i right click on the desktop, then choose run program, then I type in "GSlapt" I get red flag...
« Last Edit: June 19, 2007, 04:07:59 pm by V3ct0r » Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #4 on: June 19, 2007, 04:11:24 pm »

gslapt is found in the menu, under system.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
V3ct0r
Member
*
Posts: 19


« Reply #5 on: June 19, 2007, 04:17:17 pm »

I found it now, thanks

I have GSlapt open, but if I try to install it says that there are dependencies missing so how do I fix the dependencies?       
 "x11>=6.9.0"  is one of them, that sounds nasty...
« Last Edit: June 19, 2007, 04:24:15 pm by V3ct0r » Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #6 on: June 19, 2007, 04:28:56 pm »

actually, x11 6.9.0 is already installed on VL 5.8...

Could you try installing rosegarden with slapt-get, that way you can copy and past the errors you get in your terminal here for us to look at. Use this command:

Code:
slapt-get --install rosegarden

What does your terminal say?
Logged

V3ct0r
Member
*
Posts: 19


« Reply #7 on: June 19, 2007, 04:31:39 pm »

=)

root:# slapt-get --install rosegarden

Reading Package Lists... Done
Excluding rosegarden, use --ignore-dep to override
The following packages have unmet dependencies:
  arts: Depends: qt >= 3.3.7-i586-5vl58
The following packages have been EXCLUDED:
  rosegarden
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #8 on: June 19, 2007, 04:39:00 pm »

Ah..yes, you need to add the patches repository too.
As root (you can just copy and paste this into your terminal):

Code:
echo "SOURCE=ftp://ftp-osl.osuosl.org/pub/vectorlinux/veclinux-5.8/patches/" >> /etc/slapt-get/slapt-getrc

Then run Gslapt again, hit the Update button and select the rosegarden package once again and this time it should work.  Smiley

Edit: fixed the command  Tongue
« Last Edit: June 19, 2007, 04:46:09 pm by easuter » Logged

V3ct0r
Member
*
Posts: 19


« Reply #9 on: June 19, 2007, 04:58:26 pm »

I added this line

echo "SOURCE=ftp://ftp-osl.osuosl.org/pub/vectorlinux/veclinux-5.8/patches/" >> /etc/slapt-get/slapt-getrc

then I used this command again

root:# slapt-get --install rosegarden


but I got the same:

Reading Package Lists... Done
Excluding rosegarden, use --ignore-dep to override
The following packages have unmet dependencies:
  arts: Depends: qt >= 3.3.7-i586-5vl58
The following packages have been EXCLUDED:
  rosegarden
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done


DO I have to restart my computer in between somewhere?
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #10 on: June 19, 2007, 05:01:03 pm »

Did you update the package list after running that command?
Logged

V3ct0r
Member
*
Posts: 19


« Reply #11 on: June 19, 2007, 05:26:04 pm »

No I hadnt, but now that I did, it worked O.O

Where would I be without you, my dear Vectorian comarade?

See I love so much my VL that I made a brand new bootsplash based upon what I think of VL: the Rising Commet!!


This image was, btw 100% made with VL STD tools (gimp) even though this has nothing to do with Rosegarden =P

Thanks again
« Last Edit: June 19, 2007, 06:03:15 pm by V3ct0r » Logged
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1545


I like the bass to go BOOM!


WWW
« Reply #12 on: June 20, 2007, 12:07:29 am »

Unfortunately the version is still 1.4.0. I tried building 1.5.1 but I got stuck on lilypond which needs gcc4.

What do you plan to use rosegarden for? Sequencing, or notation? I'm using it for sequencing my midi devices.
Logged

Most music on my soundcloud page was arranged in programs running on VL.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #13 on: June 20, 2007, 03:47:08 am »

Glad to hear you have it working .

Nice gimp job on that comet  Smiley
« Last Edit: June 20, 2007, 01:28:51 pm by easuter » Logged

V3ct0r
Member
*
Posts: 19


« Reply #14 on: June 20, 2007, 12:58:11 pm »

Quote from: The Headacher
What do you plan to use rosegarden for? Sequencing, or notation? I'm using it for sequencing my midi devices.

I want to use for composition, to replace pencil and music paper. And also to play back to me what I just wrote =)

Quote from: easuter
Nice gimp job on that comet  Smiley

Thanks =)
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!