Please support VectorLinux!

Author Topic: installing Netgear MA101 USB wifi card (Atmel AT76C5XXx WLAN chip)  (Read 3011 times)

Maniqui

  • Member
  • *
  • Posts: 19
Hi all,

after achieved to install VL 5.8 Standard Gold, I have a new challenge: make he Netgear MA101 USB wifi card work in VL.
What I know:
- the card works fine
- the card works in Xubuntu Linux (I was able to connect to the internet using this card with Xubuntu Live CD)
- the USB ports works fine
- when I run 'lsusb' as root, it displays:
Bus 1 Device 2: ID 0864:4102 NetGear, Inc. MA101 802.11b Adapter
- it is the Rev. B of this card.

Homepage of the Open Source driver:
http://atmelwlandriver.sourceforge.net/
A HOW-TO
http://atmelwlandriver.sourceforge.net/howto/
Download page:
http://atmelwlandriver.sourceforge.net/downloads.html

Right now, I'm stucked.

What I have already done:

- I have download the latest version of the driver at SourceForge. That is:
atmelwlandriver-3.4.1.1  (July 22, 2005)
- I have followed the steps (not all yet) from the README (you can take a look here: http://pastebin.com/933145)

- more precisely: I'm at the STEP 1... so far, I have recompiled the kernel but I still have to put it in the /root folder.

I'm posting both for help/advices (please, take a look at the README) and to make a "journal" of the process.

BTW: for some unknown reason (not sure if it's related to all the things I have done to my clean VL install just to try to install the NetGear card), I have lost the VL-HOT capabilities for USB pendrives... :(
If I connect a pendrive, it appears if I type "lsusb" or "dmesg", but it's not listed on /dev/ nor with "fdisk -l", so I can't mount it.