VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: "suddenly", I can't mount USB pendrives  (Read 2549 times)

Maniqui

  • Member
  • *
  • Posts: 19
"suddenly", I can't mount USB pendrives
« on: June 20, 2007, 09:35:18 pm »

Hi all.

For some unknown reason (not sure if it's related to all the things I have done to my clean VL install just to try to install the NetGear card), I have lost the VL-HOT capabilities for USB pendrives... :(

If I connect an USB pendrive, it appears when I type "lsusb" or "dmesg", but it's not listed on /dev/ nor with "fdisk -l", so I can't mount it.

Any advice to know where to take a look?

Thanks in advance.





Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: "suddenly", I can't mount USB pendrives
« Reply #1 on: June 20, 2007, 09:55:29 pm »

If it doesn't doesn't show up in fdisk-l, then it's a very low-level problem. It's not getting recognized by the kernel or udev. Run udevmonitor in a root console and plug in the pendrive, post the output if any. You should also run "tail -f /var/log/messages" in another console while you're at it.
« Last Edit: June 20, 2007, 09:57:17 pm by Joe1962 »
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

Maniqui

  • Member
  • *
  • Posts: 19
Re: "suddenly", I can't mount USB pendrives
« Reply #2 on: June 20, 2007, 10:15:12 pm »

thanks for your quick reply, Joe1962.

I will try that, but in the meanwhile, I tell you that I have added a recompiled kernel (that I have built for my USB wi-fi card, as you can read in the link above) to my boot options in LILO and then booted from that kernel...
and you know what?

VL-HOT capabilities are back!

When I achieve a successful install of my USB wlan card (I have faith), I will do a complete clean reinstallation of VL.
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: "suddenly", I can't mount USB pendrives
« Reply #3 on: June 20, 2007, 10:40:14 pm »

VL-HOT capabilities are back!
That's good to hear... :)
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10