VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Startup Music  (Read 2109 times)

OU812

  • Vectorite
  • ***
  • Posts: 156
Startup Music
« on: May 22, 2007, 07:52:24 am »

Hello. I just installed the latest soho iso on my main box. Recently, it stopped playing the beautiful music that usually plays when the kde desktop is loaded; it now plays either an abbreviated version of it or a different sound entirely. I did some searching in the forums, but couldn't find any specific mention of this problem. I poked around the system and found a tool for configuring various system sounds, but the startup sound pointed to the correct .ogg file (I verified it by playing the sound). So I don't know what's wrong. Any ideas? Thanks.

john
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Startup Music
« Reply #1 on: May 22, 2007, 09:54:00 am »

Recently, it stopped playing the beautiful music that usually plays when the kde desktop is loaded...

Beautiful? Well maybe Beethoven's 9th, but not the KDE startup jingle!  ;)

Anyways, have you recently loaded any packages that are sound based? - because perhaps they are interfering with the KDE sound system. Try: KDE Control Center, Sound System, Auto Suspend and change it from 60 seconds to 2 seconds.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

OU812

  • Vectorite
  • ***
  • Posts: 156
Re: Startup Music
« Reply #2 on: June 27, 2007, 10:09:00 pm »

I tried this solution, but it didn't fix the problem: during startup, I get just a short sound file that gets played. For some reason, a few days later, the startup sound did play, but it kept breaking up. Also, other system sounds break up occasionally, or perhaps sound "static-y." I also get errors when running k3b - I get a pop-up that says there is a problem with sound system and in the same box claims that there are no problems with the sound system.

Additionally, I have soho 5.8 on a second machine. The same problem is occuring there, too.

Any help is appreciated. Thanks.

john
Logged

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: Startup Music
« Reply #3 on: June 27, 2007, 11:31:33 pm »

Another thing to try is disable kde's sound system (aRts) altogether, you can do that in the control center as well. You don't really need it for anything anyways. Sound will work fine without it, I suppose it was too much of a hassle to rip it out of KDE when the author of aRts decided it had some fundamental flaws and stopped developing it, eventhough that was more than 2.5 years ago.
Logged
Most music on my soundcloud page was arranged in programs running on VL.

OU812

  • Vectorite
  • ***
  • Posts: 156
Re: Startup Music
« Reply #4 on: June 28, 2007, 09:21:02 pm »

Thank you for your reply, but it did not work. What I think finally did work is this: enable the sound system and check the "skip prevention" box. So far, everything works.

Well. Hmm. I still had a problem with the sound breaking up. So I disabled the sound system. Startup and shutdown .ogg files play fine. Event sounds are still breaking up. This is occuring on two machines. I have not had this problem with other distros. Motherboard soundcard is disabled in the bios. I really want to use this distro, but if there is a problem with the sound system...

john

EDIT:
I can play mp3 files in amarok without problems. I can play all the sounds in the system notifications tab in the control center. The sounds that are still breaking up are the sounds made when a window closes, or a file is saved in firefox. Maybe I can just turn these off? If so, how? Thanks.
« Last Edit: June 29, 2007, 08:35:45 pm by OU812 »
Logged