VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: blacklisting the nouveau driver in VL7.1 light  (Read 167 times)

YeOldeFarte

  • Member
  • *
  • Posts: 10
blacklisting the nouveau driver in VL7.1 light
« on: August 08, 2015, 05:51:44 am »

Greetings.  The blacklisting of the nouveau driver in vectorlinux 7.1 light is difficult to do.  The proprietary nvidia installer even suggested that this might be do to its inclusion in the inital ramdisk.  Any ideas?  I am trying to install the proprietary nvidia 340 driver on my core2duo compal fl90 with VL7.1 light.  Steam comes next.
Thanks.
Logged

roarde

  • Vectorian
  • ****
  • Posts: 625
  • move the needle
Re: blacklisting the nouveau driver in VL7.1 light
« Reply #1 on: August 08, 2015, 09:28:17 pm »

I tried working this out here, but could only go so far because Nvidia's installer checks for an Nvidia gpu before finishing the install, and that's not what I have. But it does look like nouveau load in initrd is what's blocking you.

While I do "have a clue", I do not really *know* what I'm doing here, so back up /boot/initrd.gz and the entire directory /boot/initrd-tree before proceeding. Very likely you'll want to restore them. Leave the original copy of /boot/initrd-tree in place, because it's read by the mkinitrd command below. It's ok to leave the original /boot/initrd.gz in place as well.

Now edit the file /boot/initrd-tree/load_kernel_modules. Prefix a comment marker ("#", naturally) to the line
modprobe nouveau
There shouldn't be a need to remove nouveau modules, etc.

Check those backups one more time. When satisfied, issue the command:
mkinitrd

If lilo is your bootloader, run lilo so the new initrd.gz is loaded at boot. Grub shouldn't need this step.

Reboot. What should happen is that the vesa framebuffer will be used instead of nouveau, so your display will probably look different. Now see if nvidia installation will complete.

I thought about adding instruction for putting nvidia.ko in the initrd, but that would be making even more assumptions on my part. So please let us know how the initial driver install goes and the rest can be picked up from there.
Logged
Robert
VL 7.1 Light

roarde

  • Vectorian
  • ****
  • Posts: 625
  • move the needle
Re: blacklisting the nouveau driver in VL7.1 light
« Reply #2 on: August 08, 2015, 09:45:29 pm »

Reconsidered. I never know when I'll have time to read or post on the forum. You could probably figure the rest out, but here's what I think will get nvidia.ko loaded at boot once it's installed. Hopefully, there'll be better, more knowledgeable advice here before you want it. So, fwiw:

Edit /boot/initrd-tree/load_kernel_modules again after the nvidia driver installs. Add
modprobe nvidia
and save the file.

Now here's the part I'm even less sure of:
mkinitrd -m nvidia

The idea is to keep everything in the initrd just as it was after disabling nouveau load, except add the nvidia module and enable its loading. The mkinitrd script should find it on your main filesystem and copy it to the correct place in initrd-tree before rebuilding the initrd. Good luck.
Logged
Robert
VL 7.1 Light

YeOldeFarte

  • Member
  • *
  • Posts: 10
Re: blacklisting the nouveau driver in VL7.1 light
« Reply #3 on: August 09, 2015, 01:07:05 pm »

An erudite answer to a problem that did not show up in Slackware.  Your answer worked perfectly.  Thank you. :)
Logged

wigums

  • Packager
  • Packager
  • Vectorite
  • ****
  • Posts: 204
Re: blacklisting the nouveau driver in VL7.1 light
« Reply #4 on: August 09, 2015, 05:13:28 pm »

if you're using the huge kernel in slackware it wouldnt be a problem since theres no initrd.
Logged
When the people fear their government, there is tyranny; when the government fears the people, there is liberty.