VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: 070629 - Xine-lib, Xine-UI  (Read 1459 times)

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
070629 - Xine-lib, Xine-UI
« on: June 29, 2007, 12:32:20 pm »

The Headacher has packaged the latest Xine libraries and user interface. The packages can be downloaded from the testing repository:

Source: http://vectorlinux.osuosl.org/veclinux-5.8/source/testing/x-apps/xine-ui/
Package: http://vectorlinux.osuosl.org/veclinux-5.8/testing/x-apps/xine-ui-0.99.5-i586-1vl58.tlz

Code: [Select]
xine-ui: xine-ui (Media player)
xine-ui:
xine-ui: Frontend for playing audio/video file using xine-lib.
xine-ui:
xine-ui: Authors: Guenter Bartsch <guenter@users.sourceforge.net>
xine-ui: License: GNU GPL
xine-ui: website: http://xinehq.de/

Source: http://vectorlinux.osuosl.org/veclinux-5.8/source/testing/libs/xine-lib/
Package: http://vectorlinux.osuosl.org/veclinux-5.8/testing/libs/xine-lib-1.1.7-i586-1vl58.tlz

Code: [Select]
xine-lib: xine-lib (xine multimedia playback engine libraries)
xine-lib:
xine-lib: xine-lib is a free (GPL licensed) high-performance multimedia
xine-lib: playback engine.  The xine shared libraries are used by xine-ui (and
xine-lib: other media players and multimedia applications) for smooth video
xine-lib: processing and playback of multimedia streams such as movies, radio
xine-lib: and TV network streams, DVDs, and VCDs.
xine-lib:
xine-lib: Website: http://xinehq.de/
xine-lib: License: GNU gpl v2
xine-lib:

Post comments about these packages in this thread only.
Logged

mithion

  • Member
  • *
  • Posts: 53
Re: 070629 - Xine-lib, Xine-UI
« Reply #1 on: December 08, 2007, 07:26:43 pm »

Hi, I have a xine problem.  When I try to launch the xine video player, it crashed immediately.  If I try to launch it from the terminal, I get the following error message.

Code: [Select]
philippe:$ xine
This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  14 ()
  Serial number of failed request:  1967
  Current serial number in output stream:  1967

I'm using VL 5.8 SOHO.  The package versions xine-ui v. 0.99.5 and xine-lib v. 1.1.7.  What did I do wrong?
Logged

mithion

  • Member
  • *
  • Posts: 53
Re: 070629 - Xine-lib, Xine-UI
« Reply #2 on: December 11, 2007, 12:42:29 pm »

Ok, I recompiled the newer version of xine-lib (1.1.8) and also recompiled xine-ui (same as before 0.99.5).  I get the same error when trying to execute it.

Code: [Select]
philippe:$ xine
This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  14 ()
  Serial number of failed request:  1965
  Current serial number in output stream:  1965

Obviously, the problem is not the package, but is something with my system.  I emailed the xine developers and I'll see if they can help me trace the problem.  I'll keep you guys updated if I get an answer.
Logged