VectorLinux
October 24, 2014, 06:22:45 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: How to get a static interface set up for Wlan  (Read 2833 times)
seaken
Member
*
Posts: 18


« on: July 04, 2007, 09:22:34 pm »

Y'know, I love Vector Linux. It's my favorite distro. But I can see where someone might get put off if they had to spend an entire day setting the wireless connection. Of course, after I've gone through the steps several times it doesn't take that long. For me, it's been a good excercise in learning how to find where the settings for wireless setup are kept in the file system and in using VASM. I also think I am using a pre-release version of 5.8 SOHO (RC3?) so maybe it will get better in the final version, or in version 6.0.

I followed the directions on this forum to set up the wireless network. But try as I might the VASM simply would not set up the wireless. I finally got it working (and I am online here with this wireless connection) but I still don't understand why VASM does not set the interfaces to a fixed number. I set the "alias" lines in /etc/modprobe.conf to the following:

alias etho via-rhine
alias eth1 ndiswrapper

I spent a lot of time trying to set up an alias for "wlan0" but I could never get it to take. Every time I rebooted the only two interfaces that would work were eth0 and eth1. I settled for using eth1 for the wireless card.

I set up the wireless interface in VASM to eth1 and I successfully connected to my ESSID. At that point I had both my wired ethernet and my wireless network each with a valid IP address. When I used ifconfig to look at the set up it listed the network ports as:

eth0 Wired Ethernet (the MAC address was for my wired port)
eth1 Wireless (MAC address was for my Broadcom wireless)

Next, I rebooted and removed the wire from the wired port. I wanted to test only the wireless connection. When the boot was finished I used ifconfig again to take a look. Now the ports looked like this:

eth0 Wireless port
eth1 Wired port

What? Why did it it switch it back? This happened earlier in the day and slowed me down. I finally figured out that I could go into VASM and edit the interface setting and get the wireless connection to work.

How am I going to set this wireless port to a static device number so that I don't have to reset the interface every time? Also, how can I use wlan0 instead of eth1 or eth0? I'm confused as to why Vector did not set up the wireless under wlan0 instead of using the ethernet device.

Anyway, I'm happy I finally got wireless working in Vector 5.8. I never did figure it out in 5.1. So, now I can take this thing out to the porch and play with Linux instead of being teathered to the wire.

Can someone help me figure out this problem of the interface switching?

Thank you,
Sean
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #1 on: July 05, 2007, 05:16:21 am »

Can someone help me figure out this problem of the interface switching?
We would normally recommend a forum search first, or at the very least a look through the FAQs and HOWTOs. Unfortunately, they were affected by a recent out of control prune. Still, the one you need is still there, as it was luckily set to "sticky":
http://www.vectorlinux.com/forum2/index.php?topic=979.0
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
seaken
Member
*
Posts: 18


« Reply #2 on: July 05, 2007, 08:16:59 pm »

Thank you Joe. That was what I was looking for. I read everything about setting up the wireless I could find using search. Apparently I didn't know what to search for.

I found the file and made the settings as instructed. Now I'll reboot and see what happens.

Silly me, for thinking VASM would setup the interfaces. I hope there will be a fix for this in future releases.

Thanks again,
Sean
Logged
seaken
Member
*
Posts: 18


« Reply #3 on: July 05, 2007, 08:33:52 pm »

That worked to keep eth1 set to the wireless MAC address. Now all I have to do is figure out how to get Vec to start the wireless connection auto-magically. I'll search around but if anyone has any hints I'll be glad to accept.

At least I don't have to reset the interface every time.

Little steps.

Thank you,
Sean
Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #4 on: July 06, 2007, 04:29:05 am »

Are you using Ndiswrapper?

You can add the commands to /etc/rc.d/rc.local.

example:
ifconfig wlan0 up
ifconfig essid <my essid>
ifconfig wlan0 dhcpcd

HTH

Bigpaws
Logged
seaken
Member
*
Posts: 18


« Reply #5 on: July 06, 2007, 02:46:27 pm »

Yes, that helps. Thank you.

As it turns out I figured out how to use the Kwlan utility in KDE. That seems to work for me.

Thanks again,

Sean

P.S - next project = getting the Synaptics driver to shut off the finger tap feature. Once that is done this VL5.8 install on this laptop will be perfect for browsing the web. I may even start using it for writing contracts and eventually drop the MS Office stuff.
Logged
seaken
Member
*
Posts: 18


« Reply #6 on: July 06, 2007, 08:50:13 pm »

I was able to successfully install the synaptics touchpad driver and turn off the finger-tap. At first I didn't know how to "install" the *.tgz file. After a little reading I tried the  'installpkg" command, which I had never attempted before, and it worked. Of course, I had to go on faith since there wasn't any indication that the drivers actually installed anywhere. But I followed through with editing the Xorg.conf file and it works.

I don't know where the driver actually ended up but Xorg seems to find it okay. I suppose there must be a log file somewhere that can show me the output of the "installpkg" command. I'll have to read up on it.

So, I now have VL 5.8 SOHO set up. But I still have a glitch in the wireless. Apparently Kwlan doesn't actually help with the DHCP stuff so unless I already have a valid IP address it won't activate the connection. I ran dhcpcd eth1 and got a good IP address but Kwlan still doesn't activate it. More work to do there. But, I'm pretty happy top have a good Linux on this laptop. Vector is doing a great job. I'll buy my next CD from the online shop.

Thanks,
Sean
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #7 on: July 07, 2007, 02:04:51 pm »

I suppose there must be a log file somewhere that can show me the output of the "installpkg" command. I'll have to read up on it.

/var/log/packages has an entry for every package installed through installpkg, gslapt, or slapt-get. Just look for the name of the package and view the contents (they're in text format). It will show all the files installed through the package and their locations.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
seaken
Member
*
Posts: 18


« Reply #8 on: July 08, 2007, 12:40:31 pm »

Thank you GrannyGeek. That saves me some time looking around. I appreciate it.

I mentioned last that I was having trouble with Kwlan. Last time I booted up VL5.8 Kwlan would not allow me to activate the wireless. I thought maybe it was not supporting DHCP. But it does support automatically setting up the WiFi connection. For some reason it was being stubborn and was not setting up the wireless. But today, it worked right away. I clicked on my SSID and clicked on "Activate" and my wireless works. Can't tell why it wasn't working before. But if this will continue to work like this I will be a happy camper.

Thanks again to everyone who helped with the setup.

Sean
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!