VectorLinux
September 20, 2014, 09:42:43 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 070707 - GOffice 0.4.0  (Read 1993 times)
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« on: July 07, 2007, 09:43:09 am »

caitlyn has packaged the latest GOffice release for VL 5.8. It can be found in the testing repo:

Package: http://vectorlinux.osuosl.org/veclinux-5.8/testing/x-apps/goffice-0.4.0-i586-2vl58.tlz

Code:
goffice: GOffice (A glib/gtk set of document centric objects and utilities)
goffice:
goffice: There are common operations for document centric applications that are
goffice: conceptually simple, but complex to implement fully.
goffice: - plugins
goffice: - load/save documents
goffice: - undo/redo
goffice:
goffice: Jody Goldberg <jody@gnome.org>
goffice: http://www.gnome.org/gnumeric
goffice: GNU General Public License, version 2

Post feedback here.
« Last Edit: September 11, 2007, 06:53:40 am by easuter » Logged

wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: August 30, 2007, 06:44:58 am »

After installing GOffice 0.4.0, I'm not able to insert any data in gnumeric. Either pressing Return after inputting data in a cell, or pasting data leads to gnumeric crashing with the following message:

Code:
gnumeric: symbol lookup error: /usr/lib/libspreadsheet-1.7.0.so: undefined symbol: format_boolean

Downgrading to Goffice 0.3.3 makes it work again.

Using VL 5.8 STD and gnumeric 1.7.0 (the only version available in the repos at the moment)

Anyone else can replicate this? Thanks.

Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #2 on: August 30, 2007, 12:32:34 pm »

Thanks wcs, I'll take a look at this as soon as possible (holidays starting tomorrow!).
Logged

metvas
Vectorite
***
Posts: 311


« Reply #3 on: August 30, 2007, 08:21:27 pm »

easuter:
Have a good holiday, Thanks for all the work and input. It is appreciated.
Darrell
Logged

Knowledge is Power, share it.
Be the change you want to see in the World
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #4 on: September 08, 2007, 10:52:07 am »

wcs, I've been playing with this problem for a bit, and all I can think of is that the new GOffice no longer provides the exact same functionality that 0.3 did, so gnumeric can't handle it.

We also seem to be using the development branch of gnumeric (1.7) instead of the stable branch...hmmm....and things are changing quite often there Roll Eyes. For example, the latest development version (0.7.12) uses gtk 2.10 (what a jump from the initially required gtk 2.6).

So the options are:

-build the latest development version against gtk 2.10
-remove the goffice package and leave things as they are.

Some input on this would be appreciated, especially if a newer gnumeric will give you any must-have features, but otherwise I'm not keen on making a package for it (especially because of the gtk upgrade).
Logged

wcs
Packager
Vectorian
****
Posts: 1144


« Reply #5 on: September 09, 2007, 04:43:12 pm »

As for me, I'm happy for the latest goffice to be removed as I've downgraded it and do not seem to miss anything in the older version.

Thanks for your help!
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #6 on: September 11, 2007, 06:53:15 am »

Goffice 0.4.0 has been removed from the patches repository.
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!