VectorLinux
September 19, 2014, 05:31:45 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: 070708 - Fluxbox 1.0RC3 custom  (Read 6447 times)
hata_ph
Moderator
Vectorian
*****
Posts: 3257


-- Just being myself --


« Reply #15 on: September 18, 2007, 04:46:25 pm »

The other option is just to edit ~/.fluxbox/menu yourself - it is very straightforward.

ya.....is easy to modify the menu file.......but feel a bit lazy cause got a lot of .desktop to add........ Cry Cry Cry

Quote
It does supply a command "fluxbox-generate-menu", which you can use, but it is not very robust at picking up all the apps you have.

Inside the menu file, there is written that a similar command for VL. fluxbox-generate-VLmenu, but dont't know how to use it..... Tongue Tongue Tongue
btw, will look into the menumaker later. Is there a menumaker package in VL repositories?

Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #16 on: September 18, 2007, 06:06:56 pm »

luxbox-generate-VLmenu, but dont't know how to use it.
Just run the command from a terminal...
Quote
btw, will look into the menumaker later. Is there a menumaker package in VL repositories?
You don't need one because it is a Python script. Just run the command from a terminal....
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
hata_ph
Moderator
Vectorian
*****
Posts: 3257


-- Just being myself --


« Reply #17 on: September 30, 2007, 06:39:08 am »

I found something very strange, I cannot use startfluxbox to use fluxbox. I have to type startfluxbox-desk to use it....
it show cannot connect to x server.....

EDIT:

I can load fluxbox by typing "xinit startfluxbox" and the startup script work......but if I type "startfluxbox-desk" the startup script will not work...any idea?

EDIT:

It seem like if I login VL using the GUI login everything work for fluxbox..... Huh Huh Huh
« Last Edit: October 01, 2007, 08:24:36 am by hata_ph » Logged
dawnsboy
Vectorite
***
Posts: 135



« Reply #18 on: October 03, 2007, 11:34:57 am »

I am not quite sure if I am reading your post correctly but I think if you direct your attention to the file located at /home/$USER/.fluxbox/startup and make it executable your issue with starting fluxbox from the command line should be resolved.  If you have an xinitrc.fluxbox (that executes startfluxbox) located at /etc/xinit and it is also executable you can select fluxbox to be the window manager of choice from vasm (use vasm from your $USER login).  Then enter "startx" from the command line.  X will start and fluxbox will be executed as window manager.

The file /home/$USER/.fluxbox/startup contains the instruction to execute "fluxbox".  Other utilities such as gkrellm or rox can be started from this file as well.

I hope that this answers your question(s) regarding starting fluxbox from the command line.

Note:  If you boot into GUI login and are using fluxbox as wm or you startx from the command line with fluxbox as window manager of choice then you can open a terminal (console) and type the generate menu command at the command line prompt.

You can manually edit fluxbox menu by opening /home/$USER/.fluxbox/menu with a text editor such as mousepad or medit. 

You will not be able to execute the .desktop files located in the /usr/share/applications folder.  Menu structures including the one used by XFCE4 reference an applications executable file or the symbolic link to an executable file.

EXAMPLE:  Launch the Firefox web browser by typing "firefox" which will execute the sym link located at /usr/bin/firefox.

For applications with executable files that are not in the path then type in the entire path plus the executable file.

EXAMPLE:  Launch Open Office Writer by typing /opt/openoffice.org2.1/program/swriter.

One may use these examples to edit fluxbox menu manually as referenced above.

Locate the desired submenu and add the executable file to it.

Example:

[submenu] (Console) <>
[exec] (Terminal) {terminal} <>

or:

[submenu] (office) <>
[exec] (OO Writer) {/opt/openoffice.org2.1/program/swriter} <>


each submenu will be closed by the tag [end]

The syntax is easy to grasp once you have opened the menu file in a text editor.







« Last Edit: October 03, 2007, 11:47:36 am by dawnsboy » Logged

Custom Mini-Itx - VL6.0 Light
hata_ph
Moderator
Vectorian
*****
Posts: 3257


-- Just being myself --


« Reply #19 on: October 03, 2007, 05:53:19 pm »

Quote
I am not quite sure if I am reading your post correctly but I think if you direct your attention to the file located at /home/$USER/.fluxbox/startup and make it executable your issue with starting fluxbox from the command line should be resolved.

I already try chmod 777 to my /home/$USER/.fluxbox/startup but it does not startup the program. But if I reset the permission for startup file to default and start fluxbox in GUI login. The startup work fine.

the menu setting for fluxbox is simple.......I have done it my own..Smiley

for your other suggestion I will try it at home.......

Logged
dawnsboy
Vectorite
***
Posts: 135



« Reply #20 on: October 04, 2007, 10:39:36 am »

Quote
I already try chmod 777 to my /home/$USER/.fluxbox/startup but it does not startup the program. But if I reset the permission for startup file to default and start fluxbox in GUI login. The startup work fine.

If you've already switched to /home/$USER/.fluxbox directory and issued the command "chmod +x startup" it should be good to go.

The VL 5.8 package for fluxbox 1.0rc3 contains the following line:

Quote
exec fluxbox

The startup file in my /home/$USER/.fluxbox directory reads:

Quote
# fluxbox startup-script:
#
# Lines starting with a '#' are ignored.

# You can set your favourite wallpaper here if you don't want
# to do it from your style.
#
# fbsetbg -f /home/vl1/wallpapers/orange-chaos.jpg
#
# This sets a black background

/usr/X11R6/bin/fbsetroot -solid black

# This shows the fluxbox-splash-screen
# fbsetbg -C /usr/X11R6/share/fluxbox/splash.jpg

# Other examples. Check man xset for details.
#
# Turn off beeps:
# xset -b
#
# Increase the keyboard repeat-rate:
# xset r rate 195 35
#
# Your own fonts-dir:
# xset +fp "/home/vl1/.fonts"
#
# Your favourite mouse cursor:
# xsetroot -cursor_name right_ptr
#
# Change your keymap:
# xmodmap "/home/vl1/.Xmodmap"



# Applications you want to run with fluxbox.
# MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
#
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
  xfce-mcs-manager &
  rox -p desktop &

# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ''exec'' before it.

exec /usr/X11R6/bin/fluxbox
# or if you want to keep a log:
# exec /usr/X11R6/bin/fluxbox -log "/home/vl1/.fluxbox/log"


As you can see this file will cause the same apps to start with fluxbox whether the user logs in from command line or from GUI Login.

Quote
the menu setting for fluxbox is simple.......I have done it my own..Smiley

It is pretty simple.  I only mentioned it because I was not sure if I had read your post correctly and I wanted to give a thorough response.   Wink

Happy Vectoring!
Logged

Custom Mini-Itx - VL6.0 Light
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!