VectorLinux
August 01, 2014, 05:35:01 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Installing K3b  (Read 2968 times)
ramesh
Member
*
Posts: 67


« on: July 09, 2007, 06:15:19 am »

Hello

How to install K3b in VL 5.8 Standard ?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #1 on: July 09, 2007, 06:21:55 am »

open gslapt and hit the update button
Then search for k3b
click the checkbox on the left and select install

_or_

From a terminal as root

Code:
# slapt-get --update
# slapt-get --install k3b
Logged

ramesh
Member
*
Posts: 67


« Reply #2 on: July 09, 2007, 07:51:33 am »

Dear MOElnx,
Issued the command slapt-get --install k3b

The out put is:

k3b is already up to date

But cant open the programme - not seen in anyof the menu and also cannot run the programme from terminal  What went wrong
{I am comparatively new to Linux}
Thanks !
Logged
newt
Vectorian
****
Posts: 1132



« Reply #3 on: July 09, 2007, 08:01:15 am »

I believe k3b has some dependencies that maybe haven't been met - kde, specifically.  Have a look here to see the necessary requirements: http://k3b.plainblack.com/requirements

I believe the reason for it not being included with Standard is due to the KDE dependency.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #4 on: July 09, 2007, 08:06:14 am »

If you installed k3b using slapt-get or gslapt, it should have taken care of the deps.

My guess is that it could be a bad .desktop file

try executing k3b as user in a terminal

look out for any error messages and post back

BTW, the full requirements for the k3b package are listed in it's meta data
http://ftp://ftp-osl.osuosl.org/pub/vectorlinux/veclinux-5.8/testing/kde/k3b-1.0.1-i586-1vl58.meta
Logged

ramesh
Member
*
Posts: 67


« Reply #5 on: July 09, 2007, 08:50:06 am »

Dear MoE-lnx,

By isuing the command    user$ k3b,    I get the following output -


k3b: error while loading shared libraries: libkparts.so.2: cannot open object file: no such file or directory


How to proceed ?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #6 on: July 09, 2007, 09:16:26 am »

Sounds like you're missing kdelibs

Code:
# slapt-get --install kdelibs
Logged

caitlyn
Packager
Vectorian
****
Posts: 2869


WWW
« Reply #7 on: July 09, 2007, 10:49:50 am »

I agree with M0E-linux.  In addition you'll need updated dvd+rw tools if you want to burn DVDs.  The updated packag in in our patches repository.  Here is the catch:  patches is NOT included in your /etc/slapt-get/slapt-getrc file by default.  There are two solutions:

1. Install a newer version of slapt-get currently in the testing repository, or
2. Add the following line to your /etc/slapt-get/slapt-getrc file:
Quote
SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/patches/

I, personally, would recommend #2.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
ramesh
Member
*
Posts: 67


« Reply #8 on: July 09, 2007, 10:38:12 pm »

Dear Moe-lnx,

issued the command --#slapt-get --install kdelibs   The out put is given below:

Reading package lists ...... Done
Excluding Kdelibs use --ignore-dep to override
The following packages have unmet dependencies:
arts: Depends: qt >= 3.3.7 -i5865vl58
The following packages have been EXCLUDED:
Kdelibs
0 upgraded, 0 newly installed0 to remove and 1 not upgraded
Done   What to do  ?     Using VL5.8 standard
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #9 on: July 10, 2007, 04:29:02 am »

Code:
# slapt-get --install qt kdelibs
Logged

caitlyn
Packager
Vectorian
****
Posts: 2869


WWW
« Reply #10 on: July 10, 2007, 08:31:38 am »

That won't do it.  You need to enable your patches repository as I described above to upgrade qt to 3.3.7. 

Quote
2. Add the following line to your /etc/slapt-get/slapt-getrc file:
Code:
SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/patches/

Then you need to update your package listing.  Only then can you install kdelibs.  The two steps are:
Quote
slapt-get --update
slapt-get --install kdelibs

Since arts and qt are dependencies of kdelibs all will be upgraded or installed.
« Last Edit: July 10, 2007, 09:26:02 am by caitlyn » Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
ramesh
Member
*
Posts: 67


« Reply #11 on: July 10, 2007, 03:01:45 pm »

Dar Caitlyn,


Added the line as you said to slapt-getrc file .  issued the command- out put is:

Sources failed to download.  Correct sources and rerun --update.  What went wrong  ?
Logged
caitlyn
Packager
Vectorian
****
Posts: 2869


WWW
« Reply #12 on: July 10, 2007, 03:40:21 pm »

One of two things went wrong:

1. You have an error (typo) on the line

-or-

2.  You lost connectivity to the ftp server.

I can't say which from here.  Check and make sure every character is right in the /etc/slapt-get/slapt-getrc file.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #13 on: July 10, 2007, 07:02:52 pm »

From what I remember, upgrading qt can fail because it needs mysql which is in the extra repository (although I ight be wrong).
If you haven't done this already, the source http://ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/extra/ should be added (and enabled) in your SOURCES tab in  the preferences in gslapt (or added to the file /etc/slapt-get/slaptgetrc).

For me the best way to do it is to have the packages, patches, extra, and testing repositories added and then enabling or disabling them in gslapt as needed. Usually, I just keep patches and extra enabled when doing an upgrade; and the testing repository enabled for installing specific packages that I would like to try.
Logged
ramesh
Member
*
Posts: 67


« Reply #14 on: July 12, 2007, 09:10:29 am »

Hi all,

Installed k3b from Gslapt.   But it is not listed in the menu.. How to include it under the menu   ?
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!