VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: installing msttf fonts  (Read 2401 times)

ramesh

  • Member
  • *
  • Posts: 67
installing msttf fonts
« on: July 09, 2007, 11:40:34 pm »

Hi All,

How to install msttf fonts in VL 5.8 standard  ?
Logged

tomh38

  • Vectorian
  • ****
  • Posts: 913
Re: installing msttf fonts
« Reply #1 on: July 10, 2007, 06:59:26 am »

I think the package you want is here:  http://www.linuxpackages.net/download.php?id=9788 (it's the MS core web fonts packaged for Slackware 11).
Logged
"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991

ramesh

  • Member
  • *
  • Posts: 67
Re: installing msttf fonts
« Reply #2 on: July 10, 2007, 08:37:49 am »

Dear tomh38,

Downloaded the .tar gz file but how to install it  ?
  Plz help
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: installing msttf fonts
« Reply #3 on: July 10, 2007, 08:50:54 am »

Looks like it's a .tgz which means you can simply install it.  Open a terminal, su to root, issue 'installpkg name_of_package.tgz' and that should do it.

HTH
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: installing msttf fonts
« Reply #4 on: July 10, 2007, 11:34:09 am »

Or if you're still using Xfce.  You can simply right click the package and then select "Install Package".

This is kinda fun!  We're quickly rebuilding our missing documentation.  lol
Logged

ramesh

  • Member
  • *
  • Posts: 67
Re: installing msttf fonts
« Reply #5 on: July 10, 2007, 04:25:25 pm »

Dear exeterdad,

Followed your suggestions.  But cant see the fonts in the OOwriter font list.
Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: installing msttf fonts
« Reply #6 on: July 10, 2007, 07:55:29 pm »

If the fonts wound up in /usr/X11R6/lib/fonts/TTF, as root you need to run
fc-cache
before the fonts will be usable in OOo.

If they're in your ~/.fonts directory, you still have to run fc-cache but can do it as user.

You may have to restart X before the fonts show up. I'm not sure about that.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller