VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Netgear WPN511 and ath_hal (Solved)  (Read 2491 times)

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Netgear WPN511 and ath_hal (Solved)
« on: July 11, 2007, 11:53:50 am »

http://linux-wless.passys.nl/query_part.php?brandname=Netgear states that the Netgear WPN511 card is Linux friendly using the MadWifi driver but that ath_hal v. => 0.9.14.9 is required. I see from lsmod that ath_hal is present but I am not sure how to verify the version.

Please point me in the right direction.

Thank You.....
« Last Edit: July 11, 2007, 04:43:06 pm by never_stop_learning »
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Netgear WPN511 and ath_hal
« Reply #1 on: July 11, 2007, 12:11:28 pm »

Try locate ath_hal

Bigpaws
Logged

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: Netgear WPN511 and ath_hal
« Reply #2 on: July 11, 2007, 12:28:51 pm »

Try locate ath_hal

Bigpaws

Thank you, Bigpaws. This is what I get:

Quote
root:# locate ath_hal
locate: warning: database /var/lib/slocate/slocate.db' is more than 8 days old
locate: fatal error: set_path_head: path_head len <= 0: 0
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Netgear WPN511 and ath_hal
« Reply #3 on: July 11, 2007, 03:07:11 pm »

Try updatedb and then locate again, that will update the file index.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: Netgear WPN511 and ath_hal
« Reply #4 on: July 11, 2007, 03:27:45 pm »

Try updatedb and then locate again, that will update the file index.

Thank you, rbistolfi.....

This looks much better:

Quote
vector:/~
root:# updatedb
vector:/~
root:# locate ath_hal
/lib/modules/2.6.18.5/net/ath_hal.ko
vector:/~
root:#
Quote

How do I deduce the ath_hal version number from this information?
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Netgear WPN511 and ath_hal
« Reply #5 on: July 11, 2007, 04:16:58 pm »

well, that is a kernel module, I guess you can do:

Code: [Select]
# insmod /lib/modules/2.6.18.5/net/ath_hal.ko
# cat /var/log/messages | grep ath_hal

Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: Netgear WPN511 and ath_hal
« Reply #6 on: July 11, 2007, 04:42:34 pm »

well, that is a kernel module, I guess you can do:

Code: [Select]
# insmod /lib/modules/2.6.18.5/net/ath_hal.ko
# cat /var/log/messages | grep ath_hal



Quote
root:# insmod /lib/modules/2.6.18.5/net/ath_hal.ko
insmod: error inserting '/lib/modules/2.6.18.5/net/ath_hal.ko': -1 File exists
vector:/~
root:# cat /var/log/messages | grep ath_hal
Jul  8 15:08:25 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  8 15:30:27 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  8 16:22:35 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  8 16:51:12 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  8 17:12:02 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  9 08:58:54 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  9 09:41:08 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  9 11:38:36 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  9 13:39:33 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  9 22:10:13 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul  9 23:52:56 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul 10 08:21:56 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul 10 17:39:54 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
Jul 11 07:39:51 vector kernel: ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
vector:/~
root:#


Outstanding! I do believe I have version 0.9.17.2 which means that the card should work.

Thank you for your assistance.....
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Netgear WPN511 and ath_hal (Solved)
« Reply #7 on: July 11, 2007, 04:54:10 pm »

You are welcome...
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: Netgear WPN511 and ath_hal (Solved)
« Reply #8 on: July 17, 2007, 08:26:53 am »

My new (used) Netgear WPN511 card arrived yesterday. Plugged it in in place of the Netgear WG511T I had been using and......

Everything works! Now to see if the WPN card really does have better range than other cards..... 8)

Thank you, again, for your assistance.
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std