VectorLinux
September 01, 2014, 03:29:01 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Can't locate /etc/wpa_supplicant.conf  (Read 1355 times)
never_stop_learning
Vectorite
***
Posts: 263


WWW
« on: July 13, 2007, 06:57:28 am »

I'm trying to access a WPA encrypted network. The EXTREMELY EXCELLENT "Wireless Networking with VectorLinux 5 and above" How-To states the following:

Quote
wpa_supplicant works by reading data from a configuration file, usually called wpa_suppplicant.conf and placed in the /etc directory.

The configuration file can sometimes be very complex, depending on the router's or access-point's configurations.
You can find a file with exaples of what the configuration file should look like by looking at the wpa_supplicant documentation, buried in /usr/doc/wpa_supplicant-version/doc/docbook/wpa_supplicant.conf.5. Its a pitty no man-page was offered, but then the wpa_supplicant --help command does have a few tips on how it should be used.

This is what a simple wpa_supplicant.conf file looks like:


Code:

ctrl_interface=/var/run/wpa_supplicant

network={
 ssid="xxxxx"
 key_mgmt=WPA-PSK
 proto=WPA
 #pairwise=TKIP CCMP

 #group=TKIP
 psk="xxxxxxx"
}


Replace xxxxxx with the correct values. The psk parameter is where you put your key or passphrase.
The pairwise and group settings depend on what type of encryption you have set for WPA/WPA2 on your router, but aren't always necessary.
Save the settings to /etc/wpa_supplicant.conf and then type this command to make sure the file can't be read by normal users:

Code:

chmod 600 /etc/wpa_supplicant.conf


That will keep your encryption key safe from regular users.

There is no /etc/wpa_supplicant.conf file. Do I create this file and copy the above referenced code?
Logged

Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #1 on: July 13, 2007, 10:04:10 am »

Yeah, there is no default wpa_supplicant file provided in /etc, since the number of options varies so much.
You can use that one as a template to start off with.

Do post back if you need some extra help with getting WPA properly configured Smiley
Logged

never_stop_learning
Vectorite
***
Posts: 263


WWW
« Reply #2 on: July 13, 2007, 11:39:37 am »

Thank you, easuter.  Cool
Logged

Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!