VectorLinux
September 16, 2014, 01:06:52 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Kernel panic Cannot open root device  (Read 3107 times)
apock627
Member
*
Posts: 35


« on: July 14, 2007, 05:52:27 pm »

Hi. I'm returning to Vector and linux after a long break and I'm a little rusty.
I've installed VL5.8 on a Toshiba Tecra A8 laptop. The main problem is being unable to adjust screen brightness and I compiled a new kernel (2.6.21) to try to get toshset working (unsuccessfully, that's another story).

Booting my new kernel ends in a kernel panic

VFS: Cannot open root device "807" or unknown block (8,07)
Please append a correct "root= " boot option

I can still boot the original kernel from lilo OK which makes it sound like there is a problem with the config of my new kernel, but I don't think it is. I have double checked the sata drivers are included, all the required filesystems. In fact i have also compiled a 2.6.21 from the config of the kernel that works, and the result is the same. Instead I think it is something to do with the boot process

When I go back through dmesg of the working 2.6.18.5 kernel, there is a line that comes up saying
BOOT_IMAGE=2.6.18.5 ro root=807
This does not come from /etc/lilo.conf. I did a grep -r BOOT_IMAGE /boot and the only match was the binary file /boot/map

My systen is a dual boot with WinXP. I have a boot.ini optoin to load lilo and it goes from there. My root partition is /dev/sda7

Is there anything else I should be checking in the kernel config?
What else can I check for clues?

Many thanks
Logged
bigpaws
Vectorian
****
Posts: 1850


« Reply #1 on: July 14, 2007, 07:34:04 pm »

The easiest is to compare the file in /boot/config... with your config which is
in linux-<your kernel>.config.

HTH

Bigpaws
Logged
apock627
Member
*
Posts: 35


« Reply #2 on: July 15, 2007, 03:49:26 am »

Thanks, good tip.
In the end I have just started from scratch and gone through every option and now it works. Boots much quicker too now. I think part of the problem was that make menuconfig wasn't saving the config for some reason, then when I did make it was using the default options (which didn't include sata).

Anyhoo, on to the next problem. In another forum.

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!