VectorLinux
July 31, 2014, 11:24:29 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: abiword plugin upgrade fails with missing deps  (Read 4440 times)
wcs
Packager
Vectorian
****
Posts: 1144


« on: July 19, 2007, 01:30:00 am »

Hello, all.

While trying to upgrade abiword-plugins through gslapt I got a dependency error: aiksaurus was missing.
After compiling aiksaurus from source, it now asks me for link-grammar. That one I had trouble compiling.

I had the packages, extra, patches, and testing repositories enabled.

Thank you
Logged
caitlyn
Packager
Vectorian
****
Posts: 2869


WWW
« Reply #1 on: August 11, 2007, 01:56:18 pm »

I have successfully packaged both Aiksaurus (English language thesaurus) and link-grammar (English language grammar checker) and I hope both will be in testing shortly.

Even if you install both of those abiword-plugins still fails as follows:

Quote
abiword-plugins: Depends: gtkmathview >= 0.7.7

That will be the next package I build.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #2 on: August 11, 2007, 03:27:20 pm »

Thank you very much, caitlyn!
Hope there are no more dependencies after this one...
Logged
MikeCindi
Tester
Vectorian
****
Posts: 1071


« Reply #3 on: August 11, 2007, 04:10:37 pm »

Shouldn't all those be in the repository before the package gets added? I note that there are several required packages listed that are not in the four package sources that I have enabled (testing, patches, packages, and extras).
Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #4 on: August 11, 2007, 05:58:11 pm »

Quote
Shouldn't all those be in the repository before the package gets added?

This one is in the "packages" repository, though. So maybe it didn't get tested (through the process of getting added to "testing" and then moved to "extra").
Logged
caitlyn
Packager
Vectorian
****
Posts: 2869


WWW
« Reply #5 on: August 11, 2007, 08:24:06 pm »

Shouldn't all those be in the repository before the package gets added? I note that there are several required packages listed that are not in the four package sources that I have enabled (testing, patches, packages, and extras).

The answer to your question is an emphatic "yes".  Someone made a mistake,

I've now packaged and installed gtkmathviewer and it, along with aiksaurus and link-grammar, should be in testing soon.  The bad news is that we are still missing at least one more dependency:

Quote
  abiword-plugins: Depends: psiconv >= 0.9.8

It's next on my list to build.  I will get this fixed one way or another.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
caitlyn
Packager
Vectorian
****
Posts: 2869


WWW
« Reply #6 on: August 12, 2007, 09:03:26 am »

I built and installed the psiconv package and sure enough the abiword-plugins upgrade then proceeded smoothly.  To review the four missing dependencies are:

aiksaurus
link-grammar
psiconv
gtkmathview

All four have now been uploaded.  It looks like the repository maintainers are taking the weekend off but all four packages should show up in testing soon and then, after a suitable period, in extra or patches.  Once that's done this problem will be solved.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #7 on: August 13, 2007, 04:32:17 am »

Great!
That's one less issue with the repos.

Thank you very much, caitlyn.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!