VectorLinux
September 02, 2014, 06:08:00 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [Solved] Can only login to newly installed XFCE as root  (Read 2220 times)
JohnKFT
Member
*
Posts: 4


« on: July 24, 2007, 03:34:21 am »

Just installed 5.8 SOHO on a modern desktop and it runs very well - even automatically enabled DRI!  The weeks I have spent on that carry-on in the past.  Also picked up the ADSL router and connected me straight to the internet.  Terrific.  I tried Vector back in 5.1 then wandered about some other distros for a while before trying it again.  Glad I did.

However, I decided to download and install XFCE for a faster, simpler and cleaner desktop.  It shows the splash then shifts to an empty blue screen on which the mouse can do nothing.  I have to ctrl-alt-backspace to log out.  However, if I log in as root (not my favourite pastime, especially on broadband) it works as it should.  I tried reinstalling but no change.  I am scratching my head, although I suspect it must be some sort of simple permissions problem - question is, where?  Can anyone help?
« Last Edit: July 25, 2007, 06:53:01 am by lagagnon » Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: July 24, 2007, 04:33:44 am »

I had something similar, but not quite the same (my screen went progrssively from white to black... very weird).
In any case, it was solved by deleting the .cache directory in home.

Check beforehand if there is anything there you might need. Or back it up. But the problem for me was caused by an xfce session save.
That was why I could use it with one user but not other.
Logged
roseway
Packager
Vectorite
****
Posts: 135



« Reply #2 on: July 24, 2007, 06:18:44 am »

This doesn't answer your question, but if you want XFCE you could install VL5.8 Standard instead.
Logged

Eric
bigpaws
Vectorian
****
Posts: 1847


« Reply #3 on: July 24, 2007, 07:40:26 am »

This might help:

Quote
Setting up KDM

If you installed Xfce system-wide and you want to use the KDE Display Manager (kdm) to start your Xfce session, you will have to create a .desktop file to teach kdm how to start the Xfce session.

First you need to find where kdm searches for its .desktop files:

  locate kde.desktop

Common locations are /usr/share/apps/kdm/sessions or /usr/local/share/kdm/sessions. Once you found the kdm session directory, you need to create a new file Xfce.desktop with the following:

  [Desktop Entry]
  Encoding=UTF-8
  Type=XSession
  Exec=/usr/local/bin/startxfce4
  TryExec=/usr/local/bin/startxfce4
  Name=Xfce 4.4
  Comment=The Xfce 4.4 Desktop Environment


Bigpaws
Logged
JohnKFT
Member
*
Posts: 4


« Reply #4 on: July 25, 2007, 12:14:26 am »

Don't jump too readily to the obvious conclusion, I say!  Because the user did not work but root did I immediately assumed it was probably a permissions problem (not unnaturally).  Last night i decided to make another user and try logging in with that.  Well, blow me down, Xfce leapt into life.  Don't know what the problem was, but something obviously got borked in the original user's settings, so I deleted that user and made a new one to replace, and all is well.  Haven't used Xfce for a while - isn't it nice?
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #5 on: July 25, 2007, 03:20:48 am »

Quote
isn't it nice?

It's good it's working now. You can mark it as SOLVED.  Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!