VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: A really dumb question (regarding kernel headers)  (Read 2885 times)

Artthou

  • Member
  • *
  • Posts: 20
A really dumb question (regarding kernel headers)
« on: July 25, 2007, 08:56:56 am »

I installed the source to the kernel (2.6.20.3) want to rebuild a module for with installpkg, and was happy to see that it showed up in /usr/src and even made the softlink linux to the directory for me.

I then noticed that I didn't even have make or gcc on my install, so I quickly went and installed them as well.

I think the make mrproper worked okay, but when I tried to make menuconfig, it complained about not finding several header files.  Is there some environment variable I am not setting so that it has the include paths it needs?  I could go in and add it to the Makefile, but there has to be something I am doing wrong, or some order of steps I messed up.

Doing a google search turned up that kernel headers are not installed, but that was likely someone trying to rebuild software that needed only headers...the headers the compiler complains about are right there in the include directory.

I am not at that PC right now, so I am going from memory.  Any insight would be appreciated.
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1871
Re: A really dumb question (regarding kernel headers)
« Reply #1 on: July 25, 2007, 09:51:11 am »

What version of Vector are you using?

Please post the output of uname -r

Bigpaws
Logged