VectorLinux
April 16, 2014, 08:04:35 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: I hosed the package manager (solved)  (Read 1225 times)
krazykrakr01
Member
*
Posts: 3



WWW
« on: August 05, 2007, 04:07:28 am »

I was in the pkg mgr the other day and it froze while installing something called dbus. Every time I would try to shut the pkg mgr(glsapt) down it would just give me that annoying sound that it was busy. After waiting about 30 mins I shut the whole x-window down using the menu (I didn't yet know about ctrl-alt-esc to kill uncooperative programs). Ever since then, when I click on the package manager (on the desktop or in the menu), it shows to be starting up in the toolbar and even asks for root password, but as soon as I give it, it dissapears. I'm still new to linux, but I can tell something is screwed up. When all this happened, I was logged in to the pidgin instant messenger and it seems it has suffered the same fate. First tried reboot(old win habit) then found the half downloaded dbus package and got rid of it. Still nothing. Any help would be appreciated.

VL5.8SOHO-final;Compaq desktop; 500Mhz pentium 3; 384MB RAM; 512MB swap; S3inc Savage 4 vid card
« Last Edit: August 06, 2007, 09:09:37 pm by krazykrakr01 » Logged

krakr01

computer1: 3.2GHz Duo Core intel p4; 1GB RAM; Ubuntu 9.04 /windoze vista (dual)
computer2: 500mhz intel p3; 256mb RAM; Slackware server
computer1: 500mhz intel p3; 384mb RAM; VL5.8 SOHO-final /windoze xp (dual)
krazykrakr01
Member
*
Posts: 3



WWW
« Reply #1 on: August 06, 2007, 09:17:31 pm »

I took a trip into /ect/slapt-getrc in midnight commander as root. I noticed that there were no sources enabled. I enabled a few and now gslapt comes up w/ no problem. What can I say? n00b. For newbies: if you have the same problem you have to edit the text file slapt-getrc as root.
Syntax-replace DISABLED=    with      SOURCE=

If you just erase disabled it won't work.

Pidgin still doesn't work but I figure I can fix this by uninstall and reinstall through gslapt.



Pidgin don't work because the half installed dbus package is a dependant.
« Last Edit: August 09, 2007, 12:09:48 am by krazykrakr01 » Logged

krakr01

computer1: 3.2GHz Duo Core intel p4; 1GB RAM; Ubuntu 9.04 /windoze vista (dual)
computer2: 500mhz intel p3; 256mb RAM; Slackware server
computer1: 500mhz intel p3; 384mb RAM; VL5.8 SOHO-final /windoze xp (dual)
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!