VectorLinux
July 23, 2014, 01:33:44 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Krusader: problem with start  (Read 1807 times)
sebisdad
Member
*
Posts: 4


« on: July 29, 2007, 09:09:09 am »

Installed Krusader and got following message, when starting:
krusader: error while loading shared libraries: libexpat.so.1: cannot open shared object file: No such file or directory
What do i have to install to have this library, and mayba some others ?
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #1 on: July 29, 2007, 09:14:46 am »

Huh

First try /sbin/ldconfig (as root)

Then try: ls /var/log/packages/expat* and see if anything shows.
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
sebisdad
Member
*
Posts: 4


« Reply #2 on: July 29, 2007, 09:20:24 am »

I did it, that's the result:
root:# ls /var/log/packages/expat*
/var/log/packages/expat-1.95.8-i486-1*
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #3 on: July 29, 2007, 09:47:08 am »

I did it, that's the result:
root:# ls /var/log/packages/expat*
/var/log/packages/expat-1.95.8-i486-1*


damn, how about: 'locate expat' ?
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
sebisdad
Member
*
Posts: 4


« Reply #4 on: July 29, 2007, 10:29:40 am »

root:# locate expat
/opt/seamonkey/include/seamonkey-1.1.1/expat
/opt/seamonkey/include/seamonkey-1.1.1/expat/expat.h
/opt/seamonkey/include/seamonkey-1.1.1/expat/expat_config.h
/usr/doc/libxml2-2.6.27/doc/tutorial/includexpath.c
/usr/doc/libxml2-2.6.27/html/tutorial/includexpath.c
/usr/doc/python-2.4.3/html/Python-Docs-2.4.3/lib/expaterror-objects.html
/usr/doc/python-2.4.3/html/Python-Docs-2.4.3/lib/expat-example.html
/usr/doc/python-2.4.3/html/Python-Docs-2.4.3/lib/expat-errors.html
/usr/doc/python-2.4.3/html/Python-Docs-2.4.3/lib/expat-content-models.html
/usr/doc/python-2.4.3/html/Python-Docs-2.4.3/lib/module-xml.parsers.expat.html
/usr/doc/expat-1.95.8
/usr/doc/expat-1.95.8/README
/usr/doc/expat-1.95.8/Changes
/usr/doc/expat-1.95.8/reference.html
/usr/doc/expat-1.95.8/COPYING
/usr/lib/libexpat.so.0
/usr/lib/libexpat.a
/usr/lib/libexpat.so.0.5.0
/usr/lib/libexpat.la
/usr/lib/libexpat.so
/usr/lib/python2.4/xml/dom/expatbuilder.py
/usr/lib/python2.4/xml/dom/expatbuilder.pyc
/usr/lib/python2.4/xml/dom/expatbuilder.pyo
/usr/lib/python2.4/xml/sax/expatreader.pyc
/usr/lib/python2.4/xml/sax/expatreader.pyo
/usr/lib/python2.4/xml/sax/expatreader.py
/usr/lib/python2.4/xml/parsers/expat.py
/usr/lib/python2.4/xml/parsers/expat.pyc
/usr/lib/python2.4/xml/parsers/expat.pyo
/usr/lib/python2.4/test/test_pyexpat.pyc
/usr/lib/python2.4/test/test_pyexpat.pyo
/usr/lib/python2.4/test/output/test_pyexpat
/usr/lib/python2.4/test/test_pyexpat.py
/usr/lib/python2.4/lib-dynload/pyexpat.so
/usr/include/expat.h
/usr/include/expat_external.h
/var/log/packages/expat-1.95.8-i486-1
/var/log/scripts/expat-1.95.8-i486-1
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #5 on: July 29, 2007, 10:35:39 am »

Huh, there must be a fault in the krusader packaging then, if it links to a library that clearly does not exist.
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
sebisdad
Member
*
Posts: 4


« Reply #6 on: July 29, 2007, 10:43:16 am »

Tried this package http://prdownloads.sourceforge.net/krusader/krusader-1.80.0-i486-1.tgz?download
on another PC (Slackware 12.0) and it works.
« Last Edit: July 29, 2007, 10:47:35 am by sebisdad » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!