VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: I killed the Desktop (again)  (Read 3081 times)

nubcnubdo

  • Vectorian
  • ****
  • Posts: 675
I killed the Desktop (again)
« on: July 30, 2007, 09:06:13 am »

In the course of presenting a VL 5.8 Std box to a potential owner, I was demonstrating the keystroke combination Crtl+Alt+Esc. I inadvertantly killed the entire desktop. Now that I have some time, I have restored a generic Xfce desktop with VASM, but this is not what I really want. I want the VL Desktop back.

I would rather not re-install.

IIRC, there was one line in "htop" that pertained to the Desktop being present, that would not be listed if the Desktop was not running. I would like to recall that process. Oh yeah, something about "panel" maybe. Now there is an entry named "xfce4-panel".

I would like to formalize a general procedure for this type of recovery. I'm sure the problem is common.
« Last Edit: July 30, 2007, 09:09:59 am by nubcnubdo »
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Honey, I killed the Desktop (again)
« Reply #1 on: July 30, 2007, 09:11:33 am »

Control-Alt-Esc (luanches "xkill") is meant to be used within a window not on your desktop, as you unfortunately discovered! However, in Linux the desktop is just another X component! You could simply have rebooted or even logged out and got your desktop back, you needn't have gone to VASM. What you did I think is restore from /etc/skel the default xfce configs rather than those special VL xfce configs.

Maybe the easiest way is for someone to send you their ~/.config directory from a clean machine. Mine is not clean. Maybe there is an easier way, I am not sure....
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: I killed the Desktop (again)
« Reply #2 on: July 30, 2007, 09:14:29 am »

Quote
You could simply have rebooted or even logged out and got your desktop back

I guess if that happens again, just pressing Ctrl-Alt-Backspace should do it, because it will restart X (and take you to the login screen).
Logged

nubcnubdo

  • Vectorian
  • ****
  • Posts: 675
Re: I killed the Desktop (again)
« Reply #3 on: July 30, 2007, 09:22:57 am »

I did reboot, of course. And the Desktop was not there afterwards. I had a VL Desktop as root, but a big black screen (with panel) as user.  I think what cemented the error was that the box was checked to "save session for future logins" on the Quit dialog.

If I can load this Xfce desktop from vasm, shouldn't vasm have a setting for restoring VL Desktop?

Can you tell me how to get the VL desktop back now? I must copy a folder from another working system?


« Last Edit: July 30, 2007, 10:20:37 am by nubcnubdo »
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: I killed the Desktop (again)
« Reply #4 on: July 30, 2007, 09:35:07 am »

This kind of thing happens when you have save/restore session enabled. That's why I always turn it off.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

nubcnubdo

  • Vectorian
  • ****
  • Posts: 675
Re: I killed the Desktop (again)
« Reply #5 on: July 30, 2007, 10:26:07 am »

I have a copy of ~/.config from another computer, but I cant substitute it for the other. I login as root, insert USB thumb drive, copy ~/.config to root folder, get error that directory already exists, click "Yes to All" to overwrite. No "save" is available, so I close and nothing really changes when I go to user desktop.

Please give detailed procedure for making the substitution of ~/.config directory.
« Last Edit: July 30, 2007, 10:38:57 am by nubcnubdo »
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: I killed the Desktop (again)
« Reply #6 on: July 30, 2007, 11:32:34 am »

That's because root also has  a .config directory. ~ represents the "home" of whoever is logged in, thus you were root and .config already exists.

Just login as a normal user and copy the entire .config directory to your thumb drive.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: I killed the Desktop (again)
« Reply #7 on: July 30, 2007, 12:32:01 pm »

May be in the future we could have a copy of the default vl desktop config at skel? That will allow to restore the desktop from vasm.

This kind of thing happens when you have save/restore session enabled. That's why I always turn it off.

Is hard to find a real use for that feature. I like to use kill instead xkill also, but may be nubcunubdo's client prefers xkill.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

nubcnubdo

  • Vectorian
  • ****
  • Posts: 675
Re: I killed the Desktop (again)
« Reply #8 on: July 30, 2007, 01:07:18 pm »

Well, close, but no cigar. I have original VL wallpaper/background, but the panel is still a centered Xfce bar on bottom, mouse symbol where the Vector button should be, no VASM or Gslapt access. Taskbar is on top, as in Xfce. Except for the background, very little on this Desktop is the special VL xfce: no docs, no vasm, etc.  Is there a separate setting for the panels?

EDIT: Maybe I should kill the Desktop again!
« Last Edit: July 30, 2007, 01:18:51 pm by nubcnubdo »
Logged

nubcnubdo

  • Vectorian
  • ****
  • Posts: 675
Re: I killed the Desktop (again)
« Reply #9 on: July 30, 2007, 03:52:43 pm »

The computer started having battery problems, and wouldn't post, so I trashed it. I need to wash my hands of AT motherboards, they are just too old and flakey.

We still need a recovery procedure for this issue, A restoration through vasm would be ideal.
« Last Edit: July 30, 2007, 06:02:07 pm by nubcnubdo »
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: I killed the Desktop (again)
« Reply #10 on: July 30, 2007, 04:01:10 pm »

I think the answer to the problem is here:
http://www.vectorlinux.com/forum2/index.php?topic=3422

It appears as though the permissions in /etc/skel/.config are not set correctly.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll