VectorLinux
September 22, 2014, 01:56:59 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: can't mount cd/dvd (resolved)  (Read 1827 times)
Codo
Member
*
Posts: 50



« on: July 31, 2007, 08:40:49 am »

Hi guys
I have difficults to open cd and dvd and i did'nt know what happen! i use vector linux soho 5.8 and my fstab is:
# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system>   <mount point>   <type>   <options>   <dump>   <pass>
#
# dump(Cool uses the <dump> field to determine which file systems need
# to be dumped. fsck(Cool uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# The Linux partitions
/dev/hda1 / reiserfs  noatime  0  1

# Shared Windows/Linux partition
#/dev/hda1   /mnt/dos  msdos  umask=0   0  0
#/dev/hda1   /mnt/win  vfat   fmask=111,dmask=0,quiet,shortname=mixed,user  0  0
#/dev/hda1   /mnt/win  ntfs   umask=0   0  0

# Floppy disks
# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/fd0   /mnt/floppy   auto   defaults,noauto,user   0 0
#/dev/fd1  /mnt/floppy   auto   defaults,noauto,user   0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.

# CDROM, CDWRITER, DVD
/dev/cdrom1   /mnt/cdrom1   iso9660      users,noauto,ro
/dev/dvd   /mnt/dvd   iso9660      users,noauto,ro
/dev/cdrom   /mnt/cdrom   iso9660      users,noauto,ro

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de  /mnt/nfs  nfs  defaults  0 0

# proc file system:
proc   /proc   proc   defaults   0 0

# Unix98 devpts filesystem:
none  /dev/pts  devpts  gid=5,mode=666  0 0

# Shared memory filesystem:
tmpfs   /dev/shm    tmpfs defaults 0  0

# Basic USB filesystem
sysfs  /sys  sysfs  defaults  0 0

# example of a VFAT USB pendrive
#/dev/sda1  /mnt/pendrive vfat   fmask=111,dmask=0,noauto,user,quiet,shortname=mixed 0 0


# Swap partitions
# The 'sw' option means auto activating with 'swapon -a'.
/dev/hda3   none   swap   sw   0  0
      
Is there anything wrong? Thanks for any help. Wink Grin
« Last Edit: August 01, 2007, 09:19:23 am by Codo » Logged

There are many things that I must  do before I die. But I'm Brazilian and I never give up.
Vector Standard 6.0 - Xfce
urbanvoodoo
Member
*
Posts: 18



« Reply #1 on: July 31, 2007, 10:54:16 am »

Did you use Audio cd's or data cd's?

its not possible to mount audio cd's as there is no valid filesystem on the disc. That may be the problem.
Logged
Codo
Member
*
Posts: 50



« Reply #2 on: July 31, 2007, 11:29:13 am »

I use data cd's/dvd's... Sad
Logged

There are many things that I must  do before I die. But I'm Brazilian and I never give up.
Vector Standard 6.0 - Xfce
bigpaws
Vectorian
****
Posts: 1850


« Reply #3 on: July 31, 2007, 12:20:17 pm »

How are you mounting these devices and what errors are you getting?

Bigpaws
Logged
Codo
Member
*
Posts: 50



« Reply #4 on: July 31, 2007, 12:35:49 pm »

I try to open cd/dvd clicando with the left button of mouse and choosing " mount" but simply the device does not mount and of as reply that does not have archives in cd/dvd… but when click  to eject the device make it to it…
what it can be? Previously I was using the vector soho 5.1 and everything was ok… what it can be wrong?

 Angry Undecided
Logged

There are many things that I must  do before I die. But I'm Brazilian and I never give up.
Vector Standard 6.0 - Xfce
bigpaws
Vectorian
****
Posts: 1850


« Reply #5 on: July 31, 2007, 05:48:32 pm »

There maybe a problem with the cdrom and dvd setup.

As root try this in the terminal:

ls -la /dev/hdc
ls -la /dev/hdd

Also dmesg | grep hd may also prove helpful.

Bigpaws
Logged
roseway
Packager
Vectorite
****
Posts: 135



« Reply #6 on: July 31, 2007, 10:04:14 pm »

One easy way to do this is:

Right-click on desktop, select Create New --> Link to Device --> CD-ROM Device, then enter the details as appropriate. You end up with a desktop icon which you just click on to mount and view a CD, and you can unmount and eject it with a right-click.
Logged

Eric
Codo
Member
*
Posts: 50



« Reply #7 on: August 01, 2007, 09:10:03 am »

Hello, guys!! Smiley I do like roseway said to do and works it. Grin, but when I right-click for open the cd returned this message: [mntent]: warning: no final newline at the end of /etc/fstab. I put another line afther the end of /etc/fstab but the problem continue. I can open the cd data normaly... Undecided thanks a lot.
Logged

There are many things that I must  do before I die. But I'm Brazilian and I never give up.
Vector Standard 6.0 - Xfce
Codo
Member
*
Posts: 50



« Reply #8 on: August 01, 2007, 09:24:16 am »

Ok! I gave to enter in the end of the line of /etc/fstab and took off some points that had been previously. Then now I obtain to mount and to unmount the device as roseway said to make. Obrigada! Thanks  Cheesy
Logged

There are many things that I must  do before I die. But I'm Brazilian and I never give up.
Vector Standard 6.0 - Xfce
roseway
Packager
Vectorite
****
Posts: 135



« Reply #9 on: August 01, 2007, 09:56:28 am »

You're welcome Smiley
Logged

Eric
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!