Please support VectorLinux!

Author Topic: Mouse buttons  (Read 3308 times)

larryd782

  • Member
  • *
  • Posts: 5
Mouse buttons
« on: August 03, 2007, 04:45:26 pm »
Hi I am new to Vector and like it very much. I can't get my forward and back buttons to work. In Mepis, I had to install ' imwheel' and change a few things in my xorg file and everything worked. I looked in the repos and could not find imwheel. Anybody have any ideas?  Thanks

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: Mouse buttons
« Reply #1 on: August 03, 2007, 05:17:42 pm »
Not sure about imwheel, but do you remember anything about adding ZAxisMapping "4 5" to your xorg.conf? VASM can do the same thing, BTW.
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

larryd782

  • Member
  • *
  • Posts: 5
Re: Mouse buttons
« Reply #2 on: August 05, 2007, 04:55:52 am »
Tried that, didn't help. anybody else have any ideas?

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: Mouse buttons
« Reply #3 on: August 05, 2007, 05:54:12 am »
Name make and model are better than just guessing.

Did you edit /etc/X11/xorg.conf  and add this
in the mouse section?

Option ZAxisMapping "4 5"

Note: Spelling is important

after that restarting your X server. I have never had that fail on over
many different brands.

Bigpaws

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Mouse buttons
« Reply #4 on: August 05, 2007, 05:56:58 am »
here is a imwheel package for slackware http://imwheel.sf.net/files/imwheel-1.0.0pre12-i486-1.tgz
download it and use installpkg to install it

HTH,
Uelsk8s

boilertech

  • Member
  • *
  • Posts: 30
Re: Mouse buttons
« Reply #5 on: November 22, 2007, 03:51:50 pm »
I have an MS Intellimouse. When I run "xev" in terminal it shows my 2 side buttons as being 8 and 9. I believe they need to be 6 and 7 in order for them to work as back and forward in firefox. Is there any way of remapping them?

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Mouse buttons
« Reply #6 on: November 22, 2007, 04:50:44 pm »
I think so. You need to edit, as root, the file /etc/X11/xorg.conf, this stanza:

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option      "Protocol" "auto"
Option      "Device" "/dev/mouse"
Option      "ZAxisMapping" "4 5"
EndSection

and change the ZAxisMapping line to include buttons 6 and 7, then reboot X with Ctrl-Alt-BkSpace.
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

boilertech

  • Member
  • *
  • Posts: 30
Re: Mouse buttons
« Reply #7 on: November 22, 2007, 05:02:50 pm »
Thanks for your reply.
Quote
I think so. You need to edit, as root, the file /etc/X11/xorg.conf, this stanza:
Hmmm. This is what my xorg.conf file looks like in Kubuntu
Code: [Select]
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "false"
Option "Buttons" "7"
Option "ButtonMapping" "1 2 3 6 7"
Option "ZAxisMapping" "4 5"
Option "Resolution" "100"
EndSection
  I wonder, and will probably try to set it the same as Kubuntu to see if that does anything.

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Mouse buttons
« Reply #8 on: November 22, 2007, 05:13:39 pm »
Yes, why not, give it a try...
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

boilertech

  • Member
  • *
  • Posts: 30
Re: Mouse buttons
« Reply #9 on: November 22, 2007, 05:55:32 pm »
Ok. I did it and it works now. here is what my xorg.conf looks like now.
Quote
Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/mouse"
Option      "Emulate3Buttons"   "false"
Option      "Buttons" "7"
Option      "ButtonMapping"      "1 2 3 6 7"
Option      "ZAxisMapping" "4 5"
Option      "Resolution" "100"
EndSection
Now "xev" shows the two side buttons as 6 and 7 so it works as backwards and forward in firefox. I did not install imwheel or anything else.

Darn that was almost too easy.......  ::)

admars

  • Member
  • *
  • Posts: 3
Re: Mouse buttons
« Reply #10 on: December 12, 2007, 12:45:56 am »
Hi,
I'm new to Vector Linux (installed 5.9 RC3 Monday) so far so good,

added

Quote
Option      "Buttons" "7"
Option      "ButtonMapping"      "1 2 3 6 7"
Option      "ZAxisMapping" "4 5"

to my xorg.conf and that got my side buttons working perfectly on my MS Intellimouse (USB but using a PS/2 adapter)

Just wanted to say thank,

Cheers

Al