VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Wireless VL box unable to access lan nfs server  (Read 4244 times)

Verlager

  • Member
  • *
  • Posts: 34
Wireless VL box unable to access lan nfs server
« on: August 04, 2007, 10:52:30 am »

My home networked VL 5.8 SOHO wireless connection works fine accessing the internet or pinging the other linux boxes in my home (Linksys router). My other wired network machines access the lan nfs server perfectly. But when connecting to the nfs server with the wireless VL box, as root, with:
mount -t nfs 192.168.1.107:/media/500GB/shared /media/500GB the system just hangs. Why is this?
 
« Last Edit: August 04, 2007, 06:09:21 pm by Verlager »
Logged
Fear believes; courage doubts. Fear falls upon the earth and prays; courage stands erect and thinks. Fear retreats; courage advances. Fear is barbarism; courage is civilization. Fear believes in witchcraft, in devils and in ghosts. Fear is religion, courage is science. —Robert Ingersoll

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Wireless VL box unable to access lan nfs server
« Reply #1 on: August 04, 2007, 09:02:15 pm »

There are a couple of things that can be problems.

Look at your logs. There maybe a clue to the problem.

Here are the areas to check allowed hosts.
mount points missing
Improper permissions

Bigpaws
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Wireless VL box unable to access lan nfs server
« Reply #2 on: August 05, 2007, 08:47:29 am »

yes indeed, you're mount point is missing from that command.
Logged

Verlager

  • Member
  • *
  • Posts: 34
Re: Wireless VL box unable to access lan nfs server
« Reply #3 on: August 06, 2007, 06:12:51 pm »

yes indeed, you're mount point is missing from that command.

 I don't think it is. Look closer. The mount point is /media/500GB.

mount -t nfs 192.168.1.107:/media/500GB/shared /media/500GB
Logged
Fear believes; courage doubts. Fear falls upon the earth and prays; courage stands erect and thinks. Fear retreats; courage advances. Fear is barbarism; courage is civilization. Fear believes in witchcraft, in devils and in ghosts. Fear is religion, courage is science. —Robert Ingersoll

Verlager

  • Member
  • *
  • Posts: 34
Re: Wireless VL box unable to access lan nfs server
« Reply #4 on: August 06, 2007, 06:33:36 pm »

There are a couple of things that can be problems.

Look at your logs. There maybe a clue to the problem.

Here are the areas to check allowed hosts.
mount points missing
Improper permissions

Bigpaws

Thank you for your reply. Are you referring to /etc/hosts.allow? Or /etc/exports?

My /etc/exports file has a line:
/media/500GB/shared 192.168.1.1/24(rw,no_root_squash,async)

Is this legit?


Logged
Fear believes; courage doubts. Fear falls upon the earth and prays; courage stands erect and thinks. Fear retreats; courage advances. Fear is barbarism; courage is civilization. Fear believes in witchcraft, in devils and in ghosts. Fear is religion, courage is science. —Robert Ingersoll

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Wireless VL box unable to access lan nfs server
« Reply #5 on: August 06, 2007, 07:41:15 pm »

Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Wireless VL box unable to access lan nfs server
« Reply #6 on: August 07, 2007, 08:20:58 am »

oops, sorry about that.  I didn't see the space the first time.

Does the directory /media/500GB exist (i.e. have you created it)?  And just to make sure, it's not supposed to be /mnt/media/500GB, correct?
Logged

Verlager

  • Member
  • *
  • Posts: 34
Re: Wireless VL box unable to access lan nfs server
« Reply #7 on: August 08, 2007, 12:22:15 pm »

This article may help:

http://linux.omnipotent.net/article.php?article_id=12432

Bigpaws
Helped a little, I guess. I changed the nfs exports file on the host to:
/media/500GB/shared  192.168.1.0/255.255.255.0(rw)

The ip of the client machine is 192.168.1.104, which falls into the specified range.

But still it won't connect. Frustrating because I can ping the other machine, just can't get it to grant access to the shared directory with nfs.

Why won't this work?



 
Logged
Fear believes; courage doubts. Fear falls upon the earth and prays; courage stands erect and thinks. Fear retreats; courage advances. Fear is barbarism; courage is civilization. Fear believes in witchcraft, in devils and in ghosts. Fear is religion, courage is science. —Robert Ingersoll

Verlager

  • Member
  • *
  • Posts: 34
Well, I moved on, so to speak.
« Reply #8 on: August 09, 2007, 03:50:02 pm »

Heh. Interesting developments have ensued. My problem was that while mounting nfs shares, the computer would just hang, and ^C or ^D wouldn't work, and the terminal window couldn't even be closed, except by ^+ALT+ESC. It looked like the syntax was wrong. (see above).

Then I downloaded another light-weight version of Linux, and, incredibly, the the same lockup happened! But, this time, I closed the window and looked at the mount point (/media/500GB) and there it was, mounted and perfectly accessible. Using vim I edited /etc/fstab to see if auto-loading the share would work. It didn't. What to do?

So I googled "mount and NFS" and got "http://www.cyberciti.biz/tips/ubuntu-linux-nfs-client-configuration-to-mount-nfs-share.html" and it turned out that these lightweight Linux distros omitted some programs needed by NFS; -"sudo apt-get install portmap nfs-common" -fixed everthing. Of course, the replacement distro (I'll be back!) is Debian based, and VL is Slackware based, but the point remains that portmap and nfs-common need to be installed. I could have sworn they originally were, though.

If I am completely wrong, tell me, and I will happily delete the original post. But, if this is not mis-information, we should leave it as it. Please comment as necessary.
Logged
Fear believes; courage doubts. Fear falls upon the earth and prays; courage stands erect and thinks. Fear retreats; courage advances. Fear is barbarism; courage is civilization. Fear believes in witchcraft, in devils and in ghosts. Fear is religion, courage is science. —Robert Ingersoll

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Wireless VL box unable to access lan nfs server
« Reply #9 on: August 09, 2007, 04:39:48 pm »

Yes portmap and nfs-utils have always needed to have been installed and working in order to get nfs to work. Both packages are available via gslapt.  GrannyGeek once had an nfs howto in our howto section but that went missing with our database corruption, but from what I understand it is relatively trivial to get nfs working under VL. She might be able to help you out when she gets back from holidays...
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Wireless VL box unable to access lan nfs server
« Reply #10 on: August 11, 2007, 07:23:25 pm »

I'm no expert on nfs, but I've used it for quite some time for my all-Linux home network. I work by the seat of my pants, so to speak, and don't really understand the theory. These are the lines in /etc/fstab on the laptop I'm using right now (the other computers aren't turned on):
# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de  /mnt/nfs  nfs  defaults  0 0
compaq:/    /mnt/compaq    nfs   defaults,noauto,users    0 0
hall:/     /mnt/hall     nfs   defaults,noauto,users    0 0
compaq:/mnt/win_h   /media/compaq    nfs  defaults,noauto,users    0 0

I prefer to have the lines in fstab than to do a mount command like you are using. I don't want the systems mounted automatically, which is why I use noauto. When I want to mount the hall file system, for example, I do
mount /mnt/hall
and the / of hall gets mounted, along with its subdirectories that use the same file system.

On my laptop (named Toshiba.MYDOMAIN) I have these lines in /etc/hosts:
192.168.2.11     hall.MYDOMAIN   hall
192.168.2.20   compaq.MYDOMAIN compaq

Those are fixed IP addresses I've assigned.

I have this line in /etc/exports on my laptop:
/ Toshiba(rw,async,no_root_squash) hall(rw,async,no_root_squash) compaq(rw,async,no_root_squash)

In /etc/hosts.allow I have:
ALL:192.168.2.

In /etc/hosts.deny I have:
ALL:ALL

I know that VL 5.8 Standard comes with nfs-utils and portmap (I think) already installed.

After I have fstab, hosts, hosts.allow, hosts.deny, and exports set up, I run these commands as root:
# rpc.portmap
# rpc.mountd
# rpc.nfsd
# rpc.statd
# rpc.rquotad
# exportfs -a

These commands are found in /sbin and /usr/sbin. I run them on both computers; it's probably not necessary. If a command fails, it means you need to install a package with the missing program. I've found them at slackware.com when I've needed them. I don't remember if I had to install anything additional for VL 5.8.

You may have to check firewall settings. I don't know if the firewall affects an nfs network. I always turn off the VL firewall completely and just use NAT in my router instead of a software firewall. I don't have to make any adjustments for my home network in the router settings.

Let me know if any of this helps.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller