VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: SeaMonkey Not Using xpdf  (Read 2986 times)

Pita

  • Vectorian
  • ****
  • Posts: 1344
SeaMonkey Not Using xpdf
« on: August 04, 2007, 11:45:12 pm »

VL-5.8-Standard

My seamonkey browser insists on opening .pdf files with gv instead of xpdf and gv apparently can't read the pages and gives an error with a blank page. In preferences helper applications I gave the instructions to use xpdf which is ignored.

Firefox and opera both use xpdf and the pages open correctly.

Any idea how to tweak seamonkey to open pdf files with xpdf?

Regards
Logged

incognu

  • Packager
  • Vectorite
  • ****
  • Posts: 256
    • incognu.com
Re: SeaMonkey Not Using xpdf
« Reply #1 on: August 05, 2007, 04:48:56 am »

First make sure the settings and path are correct in the Helper Applications dialogue:

Go to Edit > Preferences > Navigator > Helper Applications
select application/pdf in the list
click Edit
select "Open it with"
it should read /usr/X11/bin/xpdf in the textbox

If for some reason the settings don't take, my first guess would be to check the permissions on the mimeTypes.rdf file in your profile; you should have read and write permissions for it (mine's -rw-r--r--)

You could also double check the path with "which xpdf" but I'm fairly sure yours would be the same as mine (I'm also on 5.8 Standard)
Logged
Vector Linux 6.0 Light

Pita

  • Vectorian
  • ****
  • Posts: 1344
Re: SeaMonkey Not Using xpdf
« Reply #2 on: August 05, 2007, 07:25:14 pm »

Thanks!

My xpdf is in /usr/bin and the permissions in the mimeTypes.rdf are the same as yours.

Just to be sure I made a symlinc in /usr/X11R6/bin which changed nothing.

In Edit Helper Applications I have:
MIME Type: application/pdf
Extension: .pdf

Open it with: /usr/bin/xpdf

Then it says under file type details:
When encountered: Open these files with xpdf

Clicking OK I get Warning
Seamonkey can handle this file type internally. For such types a helper application will only be invoked if the server requests external handling.
Cancel  Proceed anyway

On the Tab bar window it says: file.pdf (application/pdf Object)

If I make gv non-executable I get a blank page only on seamonkey and at the bottom it says Running Helper ...

BTW firefox and opera open .pdf files with xpdf on their own and the site in question is: http://www.vistamar.cl/descargas/ingles/etiquetas/Vistamar_Me.pdf

In firefox and opera xpdf is opened externally whereas in seamonkey it is, would I call it embedded within the browser in a new page. And I just checked, gv can open the file properly when invoked outside seamonkey.

Regards

Regards
« Last Edit: August 05, 2007, 07:38:06 pm by Pita »
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: SeaMonkey Not Using xpdf
« Reply #3 on: August 05, 2007, 08:39:10 pm »

Open it with: /usr/bin/xpdf
VL5.8 Standard here with SeaMonkey and Open with: /usr/X11R6/bin/xpdf works fine here. Maybe your symlink is wrong. Just go into Edit, Preferences, Helpers, and edit that pdf helper app to point to the correct directory ( /usr/X11R6/bin )

In future, to find out exactly where any executable file is located you can type: "whereis myprogramname" and it will spit out the pathname to the executable.

Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

incognu

  • Packager
  • Vectorite
  • ****
  • Posts: 256
    • incognu.com
Re: SeaMonkey Not Using xpdf
« Reply #4 on: August 05, 2007, 10:56:24 pm »

Yes, /usr/X11R6/bin/xpdf works fine here (though I normally use kpdf).  I don't understand why your xpdf would be located differently from mine and lagagnon's, since we're all using 5.8 Standard.  ???

If the problem persists and you're sure the path to xpdf is set correctly, you might check with a fresh testing profile (Tools > Switch profile > manage & create) to see if profile corruption could be a problem.

Also, what version of SeaMonkey are you using?  I'm currently using 1.1.4 (the package is in testing; 1.1.3 is in patches), but I can't recall any problems using earlier versions.
Logged
Vector Linux 6.0 Light

Pita

  • Vectorian
  • ****
  • Posts: 1344
Re: SeaMonkey Not Using xpdf
« Reply #5 on: August 06, 2007, 12:23:14 am »

SeaMonkey 1.1.1

It seems that seamonkey totally ignores the settings in Helper Application. If I put save to disk it will open .pdf with gv, same if I delete all or if I put to open with a none-existing file.

Search me why xpdf is in /usr/bin I did not put it there and would it matter anyhow if the correct location is given and Helper Applications being followed.

Now I opened seamonkey as su. There are no Helper Applications and the pdf file was correctly opened with xpdf w/o me doing anything.

I changed to a Default User in profile with no effect.

So where do we go from here?? To make seamonkey behave in user as it does in root.
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: SeaMonkey Not Using xpdf
« Reply #6 on: August 06, 2007, 07:04:52 am »

You must have done an upgrade (did you do a gslapt, mark all upgrades, execute???). Something got hosed. If I were you I would shtudown SeaMonkey, delete my ~/.mozilla directory and start again. That will erase all your bookmarks and cookies and history, so you might want to save those files somewhere first.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Pita

  • Vectorian
  • ****
  • Posts: 1344
Re: SeaMonkey Not Using xpdf
« Reply #7 on: August 06, 2007, 06:04:27 pm »

You must have done an upgrade (did you do a gslapt, mark all upgrades, execute???).

Yes that what I did and will explain why xpdf is not in /usr/X11R6/bin anymore. When I rebooted after the upgrade fluxbox would not come up since 2 files were moved to /usr/bin from ..X11R6/bin.

Question why was that being done?


Quote from: lagagnon
Something got hosed. If I were you I would shtudown SeaMonkey, delete my ~/.mozilla directory and start again. That will erase all your bookmarks and cookies and history, so you might want to save those files somewhere first.

That is what I did only deleting the default profiles. Installed seamonkey-1.1.3. It still uses gv to view pdf files, however not embedded and the file can be read now.

My /home is backed-up weekly.

Thanks & regards
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2880
    • The Linux Works
Re: SeaMonkey Not Using xpdf
« Reply #8 on: August 07, 2007, 09:33:33 am »

Quote
Yes that what I did and will explain why xpdf is not in /usr/X11R6/bin anymore. When I rebooted after the upgrade fluxbox would not come up since 2 files were moved to /usr/bin from ..X11R6/bin.

Question why was that being done?

It's being done for Vector Linux 5.8.6 and beyond.  X.org 7.x and Slackware 12 don't have /usr/X11R6 anymore since they aren't R6.  All packages are being changed this way to comply with the new standards.  The good news is that VL 5.8.6 rc1 has a symlink from /usr/X11R6 to /usr to allow compatibility with older packages.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

Pita

  • Vectorian
  • ****
  • Posts: 1344
Re: SeaMonkey Not Using xpdf
« Reply #9 on: August 08, 2007, 01:03:05 am »

Quote
Yes that what I did and will explain why xpdf is not in /usr/X11R6/bin anymore. When I rebooted after the upgrade fluxbox would not come up since 2 files were moved to /usr/bin from ..X11R6/bin.

Question why was that being done?

It's being done for Vector Linux 5.8.6 and beyond.  X.org 7.x and Slackware 12 don't have /usr/X11R6 anymore since they aren't R6.  All packages are being changed this way to comply with the new standards.  The good news is that VL 5.8.6 rc1 has a symlink from /usr/X11R6 to /usr to allow compatibility with older packages.

Thanks caitlyn. I hate being left in the dark.

May be this should be generally quoted somewhere on the forum for newbies to know what to do in case that symlink you mention is not yet present in their box

regards.
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2323
Re: SeaMonkey Not Using xpdf
« Reply #10 on: August 08, 2007, 11:14:26 am »

I think that will be a problem, since there is some people doing upgrades and using that repo with 5.8 standard, may be doing a simple script to make the symlink? We could include it as a regular package, so it will be there at least for those who makes a full upgrade.
Just a thought.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!