VectorLinux
November 27, 2014, 02:37:56 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 070805 - Pidgin 2.1.0 and Pidgin-libnotify  (Read 2910 times)
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« on: August 05, 2007, 05:08:44 am »

stoichyu has packaged the latest Pidgin release and its libnotify bindings. Both are in the testing repo:

Package: http://vectorlinux.osuosl.org/veclinux-5.8/testing/net/pidgin-2.1.0-i586-1vl58.tlz

Code:
pidgin: pidgin ( GTK Instant Messenger )
pidgin:
pidgin: Pidgin(formerly Gaim) is an instant messaging program for Windows,
pidgin: Linux, BSD, and other Unixes. You can talk to your friends using AIM,
pidgin: ICQ, Jabber/XMPP, MSN Messenger, Yahoo!, Bonjour, Gadu-Gadu, IRC,
pidgin: Novell GroupWise Messenger, QQ, Lotus Sametime, SILC, SIMPLE, and
pidgin: Zephyr.
pidgin:
pidgin: Website: http://pidgin.im
pidgin: License: GNU GPL
pidgin:

Package: http://vectorlinux.osuosl.org/veclinux-5.8/testing/net/pidgin-libnotify-0.13-i586-1vl58.tlz

Code:
pidgin-libnotify: pidgin-libnotify (pidgin libnotify plugin)
pidgin-libnotify:
pidgin-libnotify: This plugin adds a libnotify interface to pidgin, enabling popups
pidgin-libnotify: much like guifications. It has some configuration options, to
pidgin-libnotify: show popups when a buddy signs on, on new messages and on new
pidgin-libnotify: conversations only.
pidgin-libnotify:
pidgin-libnotify: Author: Duarte Henriques <duarte.henriques@gmail.com>
pidgin-libnotify: Website: http://gaim-libnotify.sf.net
pidgin-libnotify: License: GNU GPL
pidgin-libnotify:
pidgin-libnotify:

Post comments here.
Logged

mithion
Member
*
Posts: 53



« Reply #1 on: August 08, 2007, 04:03:26 pm »

I'm using VL 5.8 Standard.  I saw the update for pidgin 2.1.0 show up in gslapt but it didn't let me upgrade due to a dependency issue.  Is the package only for SOHO?
Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #2 on: August 08, 2007, 09:22:36 pm »

That's strange, what exactly was the dependency issue? Do you have http://vectorlinux.osuosl.org/veclinux-5.8/patches/ in /etc/slapt-get/slapt-getrc? I think I used an updated dbus.
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
mithion
Member
*
Posts: 53



« Reply #3 on: August 09, 2007, 08:36:02 am »

well it says pidgin needs glib2  version 2.12.12 to work.  And I looked and the current version installed is 2.12.10.  I have all 5 recommended repositories (packages, patches, extra, testing and unstable) enabled.  And I've done all the upgrades so I should have the most recent packages available.  I also did a search on http://www.linuxpackages.net/ and the required glib2 version isn't there.  The most recent one offered is 2.6.0 I think. 
Logged
mithion
Member
*
Posts: 53



« Reply #4 on: August 09, 2007, 07:06:27 pm »

Ok I checked my VL SOHO box and the same problem is present.  I have gilb2 2.12.10 installed on both boxes and pidgin 2.1.0 depends on glib2 2.12.12 or more recent.
Logged
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1553


I like the bass to go BOOM!


WWW
« Reply #5 on: August 10, 2007, 01:32:05 am »

You didn't exactly build this on a clean box did you stoichyu?

The same problem here, pidgin wants 2.12.12. If I skip that dependency with the --no-dep option, others cause trouble.
Logged

Most music on my soundcloud page was arranged in programs running on VL.
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #6 on: August 12, 2007, 01:20:58 am »

No, but I took care not to update the base packages, but I guess I missed something. I'll just build a new version with a clean box. I don't even know how I got glib 2.12.12.

*EDIT*
I inspected my package and the slack-required file only requires glib-2.10.3, the stock version.

The problem is the latest version gslapt is picking up is pidgin-2.1.0-i586-2vl58.tlz, the one I built is 1vl58, I have no idea where that other package came from. I also tested my package with a clean box and it works.
« Last Edit: August 12, 2007, 02:14:32 am by stoichyu » Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1553


I like the bass to go BOOM!


WWW
« Reply #7 on: August 12, 2007, 03:02:53 am »

Oops, sorry then stoichyu  Undecided.
Logged

Most music on my soundcloud page was arranged in programs running on VL.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #8 on: August 12, 2007, 05:29:43 am »

I've removed the offending package from the patches/ repo (it never should have made it there in the first place...), so stoichyu's build is good for testing again folks.

I'm very sorry for this mix-up stoichyu  Embarrassed
« Last Edit: August 12, 2007, 05:35:51 am by easuter » Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!