VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Screensavers are slow!  (Read 2741 times)

chrisdragon

  • Member
  • *
  • Posts: 11
Screensavers are slow!
« on: August 05, 2007, 08:40:40 pm »

I noticed in the preview box they are smooth but when I test the screensaver, they move slow and choppy. I have an AMD 2800+, 2GB RAM and an X1600 Pro 512MB backing it up, what would be the deal with sluggish moving screensavers?
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Screensavers are slow!
« Reply #1 on: August 05, 2007, 08:49:56 pm »

You probably do not have the correct ATI drivers. Go to ati.amd.com and get the correct Linux driver and floow the instructions at their website EXACTLY and you should notice a significant improvement.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

chrisdragon

  • Member
  • *
  • Posts: 11
Re: Screensavers are slow!
« Reply #2 on: August 05, 2007, 11:31:04 pm »

Log file:

[Warning] Driver : can't switch OpenGL library support to XFree86 4.x.x DRI method
[Warning]        : because package xf86_glx-4.*.i386.rpm is not installed.
[Warning]        : please install and run switch2xf86_glx afterwards.
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
 Assuming default VMAP API
 Assuming default munmap API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.18.5/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.18.5'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
In file included from /lib/modules/fglrx/build_mod/2.6.x/drm_proc.h:41,
                 from /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:366:
/lib/modules/fglrx/build_mod/2.6.x/drmP.h:126:1: warning: "DRM_DEBUG_CODE" redefined
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:179:1: warning: this is the location of the previous definition
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:484: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `firegl_stub_open':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:607: warning: assignment discards qualifiers from pointer target type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `__ke_do_mmap':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1968: warning: assignment makes pointer from integer without a cast
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `__ke_smp_call_function':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4330: warning: passing arg 1 of `smp_call_function' from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `KCL_has_pat':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4512: warning: passing arg 2 of `constant_test_bit' from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4512: warning: passing arg 2 of `variable_test_bit' from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `KAS_ExecuteAtLevel':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5139: warning: 'flags' might be used uninitialized in this function
  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST
  CC      /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-2.6.18.5'
build succeeded with return value 0
duplicating results into driver repository...
done.
==============================
- recreating module dependency list
- trying a sample load of the kernel modules
done.

Did I miss something? I don't see xf86_glx-4 or switch2xf86_glx in the slaptget listing.  ??? ??? ???
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2323
Re: Screensavers are slow!
« Reply #3 on: August 06, 2007, 05:02:42 am »

Do you have the correct kernel sources installed?
Which version of VL are you using?
You can find it out doing

#cat /etc/vector-version
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

chrisdragon

  • Member
  • *
  • Posts: 11
Re: Screensavers are slow!
« Reply #4 on: August 06, 2007, 12:13:58 pm »

All I know is that I have VL 5.8 :)

Dunno about kernel version and other things.
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Screensavers are slow!
« Reply #5 on: August 06, 2007, 12:22:07 pm »

the module looks to me like it built correctly.
try changing the driver in /etc/X11/xorg.conf to fglrx and rebooting
Logged

chrisdragon

  • Member
  • *
  • Posts: 11
Re: Screensavers are slow!
« Reply #6 on: August 06, 2007, 01:34:23 pm »

Change what, renaming it or something? Here's a piece of the .conf file...

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
HorizSync 30-83
VertRefresh 56-75
EndSection

Section "Device"
### Available Driver options are:-
### Values: : integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
###
[arg]: arg optional
#Option     "ShadowFB"              # [<bool>]
#Option     "DefaultRefresh"        # [<bool>]
#Option     "ModeSetClearScreen"    # [<bool>]
Identifier  "Card0"
Driver      "vesa"
VendorName  "ATI Technologies Inc"
BoardName   "Unknown Board"
BusID       "PCI:1:0:0"
EndSection
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Screensavers are slow!
« Reply #7 on: August 06, 2007, 01:53:16 pm »

change this
Code: [Select]
Driver      "vesa"so it says this
Code: [Select]
Driver      "fglrx"
then reboot
Logged

chrisdragon

  • Member
  • *
  • Posts: 11
Re: Screensavers are slow!
« Reply #8 on: August 06, 2007, 02:34:00 pm »

Awesome, that worked! Thanks muchly!  ;D
Logged