Please support VectorLinux!

Author Topic: New Dillo package in repository -- dependency missing  (Read 4776 times)

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
New Dillo package in repository -- dependency missing
« on: August 07, 2007, 01:22:28 pm »
The following result was part of a slapt-get --upgrade:

Quote
   dillo: Depends: libpng-1.2.16 >= i486

It looks like an error in the slack-required file to me.
« Last Edit: August 08, 2007, 08:24:03 am by caitlyn »
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: New Dillo package in reository -- dependency missing
« Reply #2 on: August 07, 2007, 01:46:20 pm »
The problem is in the package basename in the deps. Should be: libpng >= 1.2.16
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: New Dillo package in reository -- dependency missing
« Reply #3 on: August 08, 2007, 08:23:43 am »
Yep, that's what I thought.  Who can correct this?
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: New Dillo package in repository -- dependency missing
« Reply #4 on: August 08, 2007, 10:23:43 am »
I can correct it this evening when I do repo maintenance (that is, if the original packager doesn't fix it first).

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: New Dillo package in repository -- dependency missing
« Reply #5 on: August 08, 2007, 01:14:50 pm »
Fixed, revision number bumped to 6vl58.

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: New Dillo package in repository -- dependency missing
« Reply #6 on: August 11, 2007, 12:04:03 pm »
I get a dependency failure:
dillo: Depends: x11 >= 7.2

Can this be ignored or is it really needed? I'm using 5.8 Standard Gold.
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: New Dillo package in repository -- dependency missing
« Reply #7 on: August 11, 2007, 12:23:14 pm »
You can probably install it with the --nodeps option.  It looks like someone built that package with an upgraded X.org or against VL5.8.6 instead of a clean VL 5.8 machine.  Probably the slack-desc file can be changed safely but that would need to be tested.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: New Dillo package in repository -- dependency missing
« Reply #8 on: August 11, 2007, 02:09:54 pm »
Nuts...I only fixed the reported problem with libpng...the x11 one will be fixed too.