VectorLinux
July 23, 2014, 03:39:13 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: Vector Installer On A UFD?  (Read 4576 times)
gacl
Vectorite
***
Posts: 218



« Reply #15 on: August 15, 2007, 07:38:29 pm »

I'm getting:

Quote
Loading
Invalid or corrupt kernel image.

Here's the extlinux.conf file:

Quote
default isolinux/kernel/sata initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=18000 rw root=/dev/ram
prompt 1
display message.txt
F1 f1.txt
label linux
  kernel isolinux/kernel/sata
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=18000 rw root=/dev/ram
label sata
  kernel isolinux/kernel/sata2
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=18000 rw root=/dev/ram
label scsi
  kernel isolinux/kernel/scsi
  append initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=18000 rw root=/dev/ram
label linux2
  kernel isolinux/kernel/sata
  append initrd=initrd.new load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=18000 rw root=/dev/ram
label sata2
  kernel isolinux/kernel/sata2
  append initrd=initrd.new load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=18000 rw root=/dev/ram
label scsi2
  kernel isolinux/kernel/scsi
  append initrd=initrd.new load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=18000 rw root=/dev/ram

I also tried the 2.6.20.3 kernel that rbistolfi suggested, but i get the same thing.
Logged

“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #16 on: August 16, 2007, 03:18:05 am »

gacl
You are one dedicated person!  Hope you get this resolved.  This has been an interesting thread.
Logged
gacl
Vectorite
***
Posts: 218



« Reply #17 on: August 21, 2007, 05:50:33 pm »

OK, it's booting now.

I started from scratch. I partitioned as /dev/sda1, then mkfs.ext3, and then i copied all of the Vector files to the drive, and then i had to use Puppy 'cause i don't think Vector has extlinux.

I created a boot directory, did extlinux -i boot, did mv isolinux/isolinux.cfg boot/extlinux.conf, moved initrd.img and the kernel folder to boot too, and now it's booting.

Now, i kind of knew this was going to happen but i get the "Something Is Wrong" box. The one that says: "ERROR ERROR ! I could not find the install media on the hard disk or the CDROM as well. Please check. . ." etc.

What do i do now?
Logged

“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #18 on: August 21, 2007, 09:03:22 pm »

Does the kernel have usb and usb mass storage device modules built-in? Or as separate modules? Also, did you put the iso in the root of the drive?
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
gacl
Vectorite
***
Posts: 218



« Reply #19 on: August 22, 2007, 02:33:12 pm »

Sweet, sweet victory!

I downloaded the ISO to one of the partitions in the drive, and. . . done! I'm writing this from Vector Linux installed in my Dell Latitude. I had to sweat this one out but it's finally done. And hopefully i learned something in the process. Thank you all!

Gus
Logged

“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!