VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Playing Audio CD's  (Read 2131 times)

mick12345678

  • Vectorite
  • ***
  • Posts: 140
Playing Audio CD's
« on: August 08, 2007, 02:48:39 pm »

If I put an audio CD in my CDROM drive, I can play it by
-  starting XMMS
-  selecting 'play location'
-  selecting '/mnt/cdrom' from the drop down list (the other option is '/dev/cdrom' - selecting that doesnt work)

Two things :

1) the CD doesn't start from the 1st track - XMMS seems to pick a track at random. If I then hit the 'next track' button, it again picks a track at random. How can I make it start at track 1 and stick to a linear order ?

2) how can I get audio CD's to autoplay (i.e. without me starting an app manually)

Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Playing Audio CD's
« Reply #1 on: August 08, 2007, 03:33:33 pm »

1) xmms doesn't do that for me so it must be something in your xmms settings.
2) if you are using KDE try this: http://www.kde-forum.org/artikel/15287/Howto-auto-play-CD-with-Xmms-in-KDE.html . Otherwise try this one: http://www.murga-linux.com/puppy/viewtopic.php?t=18056 . At any rate it requires writing a script. (The philosophy behind Linux is different to Windows. Linux assumes the user is in control of the machine, not the OS being in control of the user. Hence the reason for no automated autoplay feature for music CD's. As an example, the use might actually want to rip the music CD and not play it!).
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Pita

  • Vectorian
  • ****
  • Posts: 1332
Re: Playing Audio CD's
« Reply #2 on: August 08, 2007, 08:17:20 pm »

There is a program called cdplay. Put a CD in, type cdplay from the console or a terminal press Enter and the playing of .wav files starts. I find it very convenient. One can go in and out of X and the playing continues. Google cdplay and you will find it.

Have fun
Logged

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: Playing Audio CD's
« Reply #3 on: August 09, 2007, 12:34:40 am »

VL has cdda-player (part of the libcdio package) , that should be able to play audio cd's from console, no need to get cdplay (the cd drive in this computer is b0rken though, so I haven't actually tested).

Quote
Hence the reason for no automated autoplay feature for music CD's. As an example, the user might actually want to rip the music CD and not play it!
screens that come up whenever I insert some cd or pendrive are among the top annoyances I have with Windows. I really HATE the autoplay function in Windows. Apparently you CAN turn it off in the registry, but I'd rather not mess with that. So I'll hold the shift key instead...
Logged
Most music on my soundcloud page was arranged in programs running on VL.

Pita

  • Vectorian
  • ****
  • Posts: 1332
Re: Playing Audio CD's
« Reply #4 on: August 09, 2007, 02:15:31 am »

VL has cdda-player (part of the libcdio package)


It works the same as cdplay. Now, how will one know there is such a program if one does not know?

Is there a list of all the hidden treasures in VL?
Logged

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: Playing Audio CD's
« Reply #5 on: August 09, 2007, 03:49:02 am »

Quote
Now, how will one know there is such a program if one does not know?

Is there a list of all the hidden treasures in VL?
I used
Code: [Select]
cd[tab] to get a list of all commands that start with "cd". I don't think there is such a list, but if you check through the package descriptions you might find clues to packages that might have useful (to you) stuff in them. Then, you can find most binaries by doing something like
Code: [Select]
grep bin/ /var/log/packages/Name_of_package
Such a list would be fun, but what's treasure to me is trash to others. There are a lot of binaries in /bin and /usr/bin, I don't think anybody knows them all. There have to be some gems there :).
Logged
Most music on my soundcloud page was arranged in programs running on VL.

mick12345678

  • Vectorite
  • ***
  • Posts: 140
Re: Playing Audio CD's
« Reply #6 on: August 09, 2007, 12:40:35 pm »

Quote
xmms doesn't do that for me so it must be something in your xmms settings.
strange - just tried again, and now its behaving properly  ???
Should've said - I'm on 5.8 standard, so not KDE. Will take a look at the script thread.
Quote
I really HATE the autoplay function in Windows.
So do I ! I'm setting this PC up for someone else though, and want to make it as simple as possible for them to use (so no console typing, for example).
Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Playing Audio CD's
« Reply #7 on: August 11, 2007, 01:39:30 pm »

screens that come up whenever I insert some cd or pendrive are among the top annoyances I have with Windows. I really HATE the autoplay function in Windows. Apparently you CAN turn it off in the registry, but I'd rather not mess with that. So I'll hold the shift key instead...

Download the free PowerToys from Microsoft.com and you can turn off the autoplay without editing the Registry yourself. Get the version appropriate for your version of Windows.

You can also turn off autoplay someplace (Device Manager? Disk Management snapin? I don't have Windows running on any computer right now). That doesn't seem to work very well, though.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller