VectorLinux
October 31, 2014, 04:50:59 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Canon Powershot SD800 IS  (Read 1692 times)
solex
Member
*
Posts: 67


« on: August 11, 2007, 08:55:00 am »

Anyone have a how-to that explains how to get a USB camera connected to the computer?  there appears to be some driver issue as I cannot get the control panel applet to recognize the camera.

Thanks,
Dan
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #1 on: August 11, 2007, 10:29:39 am »

First thing to check is if there is support for your camera.

Code:
gphoto2 --list-cameras | grep Canon

in a terminal will give you an output with all the Canon cameras supported by libgphoto2.
If the camera does not appear in the list, still can work detected as a similar model. You can try as root (type su and your root password):

Code:
gphoto2 --auto-detect

to auto-detect the camera. Once you  know your camera is working you can use gtkam or digikam if you are in SOHO to handle the pictures in a gui.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
solex
Member
*
Posts: 67


« Reply #2 on: August 11, 2007, 05:30:59 pm »

Thank you for responding.

It looks like gphoto2 does not detect my camera also when I run digikam I get the following error:

digikam: error while loading shared libraries: libkexiv2.so.0: cannot open shared object file: No such file or directory
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #3 on: August 11, 2007, 06:49:15 pm »

Thank you for responding.

It looks like gphoto2 does not detect my camera

Ok, did not gphoto2 --auto-detect work? If not, I am afraid we are not very lucky and there is no much hopeness, since both, gtkam and digikam use gphoto2 as backend. May be you want to try this usage: gphoto2 --camera=MODEL. Replace MODEL with a similar cam from the output of gphoto2 --list-cameras. You need to do it as root because users dont have access to usb by default. Another thing to do is type as root lsusb, write the ID of your camera and google for a model which has the same ID. If you find another model with the same ID and it is in the gphoto2 list, just use that camera instead yours.

Quote
also when I run digikam I get the following error:

digikam: error while loading shared libraries: libkexiv2.so.0: cannot open shared object file: No such file or directory

How did you install Digikam? It is shipped by default with soho, so I guess you have the standard edition. I use standard too, and I have digikam installed, dont remember how I did it though  Embarrassed. Anyway, I did

Code:
slapt-get --install digikam


and looks like slapt-get will pull all the dependencies. You need the patches and the testing repo enabled. You can do it with gslapt, but I prefer to edit the file manually. Open as root the file /etc/slapt-get/slaptgetrc and add this:

Code:
SOURCES=http://vectorlinux.osuosl.org/veclinux-5.8/patches/
SOURCES=http://vectorlinux.osuosl.org/veclinux-5.8/extra/
SOURCES=http://vectorlinux.osuosl.org/veclinux-5.8/testing/

Save the file and then try:

Code:
slapt-get --update
slapt-get --install digikam

Is a 36mb download, sorry I have not the disk space to test if it works. May be one of the guys installed digikam in standard recently and wants to jump in?

« Last Edit: August 11, 2007, 07:34:39 pm by rbistolfi » Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Trio3b
Member
*
Posts: 58


« Reply #4 on: August 12, 2007, 06:15:32 pm »

Using VL 5.8 with gtkam. Am having same issue regarding Canon powershot A430.  It is listed as supported in the gphoto2 database in PTP mode, but will not initialize camera. I suspect it is because I cannot find a way to place camera into PTP mode. Strange thing is Digikam in Mandrake 10.2 does connect to it in PTP mode so I don't know how that is happening.

Anyway, until I figure this out, I am using a USB card reader as  a short workaround for VL that works fine.

Hope this helps
« Last Edit: August 12, 2007, 06:29:03 pm by Trio3b » Logged
Trio3b
Member
*
Posts: 58


« Reply #5 on: August 12, 2007, 06:30:37 pm »

Wow, not 5 minutes later, I opened gtkam in terminal as root and now camera is detected. I had this issue with an external serial port modem and it turned out to be a permissions issue.

check here -> http://www.lockergnome.com/nexus/linux/2005/06/06/set-up-gphoto2-for-non-root-users/

and here -> http://gphoto.org/doc/manual/permissions-usb.html

Let us know if you have any luck.
« Last Edit: August 12, 2007, 09:34:46 pm by Trio3b » Logged
solex
Member
*
Posts: 67


« Reply #6 on: August 13, 2007, 06:36:16 pm »

Update, I loaded libkexiv2.so.0 and now gphoto works at the time I connected it to my windows machine to try to load the pictures which started to work but my battery died.

I tried mounting the SD card with my card reader but am no getting the following error:

FAT: logical sector size too small for device (logical sector size = 512)

I issued the following mount command:  root:# mount -t usbfs -o loop /dev/sdd1 /mnt/memory     

It appears from my research that SDHC cards are not yet universally supported.  Can anyone confirm this or help with mounting the card?

Thank you everyone,
Dan
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!