VectorLinux
September 16, 2014, 03:01:34 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Can print jpeg image from Firefox but not GQview or Gimp  (Read 3250 times)
rhauff
Vectorite
***
Posts: 105


« on: August 16, 2007, 06:09:38 am »

Printing images from GQview used to work, but recently quit functioning.  It does send Something to the printer (a networked Brother MFC5840), the printer lights up and says receiving data, but nothing comes out.  I tried Gimp, but get the same results.  Next I tried Firefox, which worked fine, but of course gives no options for resizing the image.

I don't understand the relationship between Xfprint and CUPS, or why the print options are so varied between applications.  GQview just shows "default printer" as the destination, Gimp shows "*Brother_MFC-5840CN_192.168.1.102", and Firefox shows "CUPS/Brother_MFC-5840CN_192.168.1.102"

The most recent significant upgrade a few weeks ago was to XFCE 4.0, this is on VL5.8 std.  I may not have tried printing with GQview since then.\

Thanks!
Logged
rhauff
Vectorite
***
Posts: 105


« Reply #1 on: November 06, 2007, 04:50:32 am »

Hey,
Any printing experts out there?  I'm trying to print from this PC again today.

I did notice in gqview that there is "Custom Printer" in the destination list, with "lpr -P Brother_MFC-5840CN_192.168.1.102" in the Custom Printer box.  I tried this, but no dice as well.  The printer lights up for a few seconds, but nothing comes out.

I am able to print fine from Abiword and OpenOffice as well, and just used Ooo Draw  to format the image, which worked nicely.  Also recently installed Picassa (the currently distributed wine version) and it shows no print options.  I'm guessing it's related to my Gimp & Gqview problems.
« Last Edit: November 06, 2007, 05:13:16 am by rhauff » Logged
rhauff
Vectorite
***
Posts: 105


« Reply #2 on: November 06, 2007, 10:26:26 am »

In gqview I tried printing to file, which seems to work.  I then right clicked on the file in Thunar and chose Print.  This prints, but instead of an image, it prints out pages of garbage text.  Is this a clue to something?Huh
Logged
JohnB316
Administrator
Vectorian
*****
Posts: 1346


Registered Linux User #386728


« Reply #3 on: November 11, 2007, 09:10:40 am »

rhauff,

I'm not necessarily a printing expert. With that said, though, have you tried printing to the "Default Printer" in gqview? You should be able to select it from the Print -> Printer -> Destination tab. At least that's what the documentation for gqview at http://gqview.sourceforge.net/docs/9_printing.html says.

that's the setting that gave you problems, then there's probably a communication issue somewhere. We'll need to dig into CUPS to find out if that's the case. Open the CUPS web interface by typing 127.0.0.1:631 in your browser's address bar. Once you are in the web interface, if you are using CUPS 1.2.x or later, click on Administration -> Edit Configuration File. Once you are in the configuration file, you will see a block of text looking something like this:

Code:
# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel info


Change the logging level from "info" to "debug" (without quotes) then click on "Save Changes." You may be prompted for a user name and password - enter root and the password for root here.

Now try to print from gqview again to your default printer. If you still get no communication, then post the contents of /var/log/cups/error_log. Again, CUPS 1.2.x or later makes for easy access to this info - click on Administration -> View Error Log to see the messages being logged.

HTH some,
John
Logged

VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.
rhauff
Vectorite
***
Posts: 105


« Reply #4 on: November 13, 2007, 08:25:21 am »

Thanks for the reply.  Yes, Default Printer is what I started with in gqview.  I will try your suggestion on the Cups debugging next time I need to print.
Logged
rhauff
Vectorite
***
Posts: 105


« Reply #5 on: November 16, 2007, 11:06:50 am »

What a huge amount of messages!!!  Here is just the section of error_log from 1 print attempt.  It does mention a crash about 2/3 of the way down ( (/usr/lib/cups/filter/pstops) crashed on signal 11!).  Hopefully something is meaningful here:

D [16/Nov/2007:13:01:08 -0600] cupsdAcceptClient: 6 from localhost:631 (IPv4)
D [16/Nov/2007:13:01:08 -0600] cupsdReadClient: 6 POST / HTTP/1.1
D [16/Nov/2007:13:01:08 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:08 -0600] CUPS-Get-Printers
D [16/Nov/2007:13:01:08 -0600] cupsdProcessIPPRequest: 6 status_code=0 (successful-ok)
D [16/Nov/2007:13:01:08 -0600] cupsdReadClient: 6 POST / HTTP/1.1
D [16/Nov/2007:13:01:08 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:08 -0600] CUPS-Get-Classes
D [16/Nov/2007:13:01:08 -0600] cupsdProcessIPPRequest: 6 status_code=0 (successful-ok)
D [16/Nov/2007:13:01:08 -0600] cupsdReadClient: 6 POST / HTTP/1.1
D [16/Nov/2007:13:01:08 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:08 -0600] CUPS-Get-Default
D [16/Nov/2007:13:01:08 -0600] cupsdProcessIPPRequest: 6 status_code=0 (successful-ok)
D [16/Nov/2007:13:01:08 -0600] cupsdReadClient: 6 POST / HTTP/1.1
D [16/Nov/2007:13:01:08 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:08 -0600] CUPS-Get-Printers
D [16/Nov/2007:13:01:08 -0600] cupsdProcessIPPRequest: 6 status_code=0 (successful-ok)
D [16/Nov/2007:13:01:08 -0600] cupsdCloseClient: 6
D [16/Nov/2007:13:01:18 -0600] cupsdAcceptClient: 6 from localhost:631 (IPv4)
D [16/Nov/2007:13:01:18 -0600] cupsdReadClient: 6 POST / HTTP/1.1
D [16/Nov/2007:13:01:18 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:18 -0600] CUPS-Get-Printers
D [16/Nov/2007:13:01:18 -0600] cupsdProcessIPPRequest: 6 status_code=0 (successful-ok)
D [16/Nov/2007:13:01:18 -0600] cupsdReadClient: 6 POST / HTTP/1.1
D [16/Nov/2007:13:01:18 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:18 -0600] CUPS-Get-Classes
D [16/Nov/2007:13:01:18 -0600] cupsdProcessIPPRequest: 6 status_code=0 (successful-ok)
D [16/Nov/2007:13:01:18 -0600] cupsdReadClient: 6 POST / HTTP/1.1
D [16/Nov/2007:13:01:18 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:18 -0600] CUPS-Get-Default
D [16/Nov/2007:13:01:18 -0600] cupsdProcessIPPRequest: 6 status_code=0 (successful-ok)
D [16/Nov/2007:13:01:18 -0600] cupsdAcceptClient: 7 from localhost:631 (IPv4)
D [16/Nov/2007:13:01:18 -0600] cupsdCloseClient: 6
D [16/Nov/2007:13:01:18 -0600] cupsdReadClient: 7 POST /printers/Brother_MFC-5840CN_192.168.1.102 HTTP/1.1
D [16/Nov/2007:13:01:18 -0600] cupsdAuthorize: No authentication data provided.
D [16/Nov/2007:13:01:18 -0600] Print-Job ipp://localhost/printers/Brother_MFC-5840CN_192.168.1.102
D [16/Nov/2007:13:01:18 -0600] print_job: auto-typing file...
D [16/Nov/2007:13:01:18 -0600] print_job: request file type is application/postscript.
D [16/Nov/2007:13:01:18 -0600] add_job: requesting-user-name="roland"
I [16/Nov/2007:13:01:18 -0600] Adding start banner page "none" to job 262.
D [16/Nov/2007:13:01:18 -0600] Discarding unused job-created event...
I [16/Nov/2007:13:01:18 -0600] Adding end banner page "none" to job 262.
I [16/Nov/2007:13:01:18 -0600] Job 262 queued on "Brother_MFC-5840CN_192.168.1.102" by "roland".
D [16/Nov/2007:13:01:18 -0600] Job 262 hold_until = 0
D [16/Nov/2007:13:01:18 -0600] Discarding unused printer-state-changed event...
D [16/Nov/2007:13:01:18 -0600] job-sheets=none,none
D [16/Nov/2007:13:01:18 -0600] banner_page = 0
D [16/Nov/2007:13:01:18 -0600] [Job 262] argv[0]="Brother_MFC-5840CN_192.168.1.102"
D [16/Nov/2007:13:01:18 -0600] [Job 262] argv[1]="262"
D [16/Nov/2007:13:01:18 -0600] [Job 262] argv[2]="roland"
D [16/Nov/2007:13:01:18 -0600] [Job 262] argv[3]="(stdin)"
D [16/Nov/2007:13:01:18 -0600] [Job 262] argv[4]="1"
D [16/Nov/2007:13:01:18 -0600] [Job 262] argv[5]="job-uuid=urn:uuid:63821227-a0dc-32a6-4579-03ef05264316"
D [16/Nov/2007:13:01:18 -0600] [Job 262] argv[6]="/var/spool/cups/d00262-001"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[1]="CUPS_DATADIR=/usr/share/cups"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[2]="CUPS_DOCROOT=/usr/share/doc/cups"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[5]="CUPS_SERVERBIN=/usr/lib/cups"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[6]="CUPS_SERVERROOT=/etc/cups"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[7]="CUPS_STATEDIR=/var/run/cups"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[8]="PATH=/usr/lib/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[9]="SERVER_ADMIN=root@vector.linux.net"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[10]="SOFTWARE=CUPS/1.2.9"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[11]="TMPDIR=/var/spool/cups/tmp"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[12]="USER=root"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[13]="CUPS_SERVER=localhost"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[14]="CUPS_ENCRYPTION=IfRequested"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[15]="IPP_PORT=631"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[16]="CHARSET=iso-8859-1"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[17]="LANG=en_US"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[18]="PPD=/etc/cups/ppd/Brother_MFC-5840CN_192.168.1.102.ppd"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[19]="RIP_MAX_CACHE=8m"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[20]="CONTENT_TYPE=application/postscript"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[21]="DEVICE_URI=socket://192.168.1.102"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[22]="PRINTER=Brother_MFC-5840CN_192.168.1.102"
D [16/Nov/2007:13:01:18 -0600] [Job 262] envp[23]="FINAL_CONTENT_TYPE=printer/Brother_MFC-5840CN_192.168.1.102"
I [16/Nov/2007:13:01:18 -0600] Started filter /usr/lib/cups/filter/pstops (PID 11627) for job 262.
I [16/Nov/2007:13:01:18 -0600] Started filter /usr/lib/cups/filter/brlpdwrapperMFC5840CN (PID 11628) for job 262.
I [16/Nov/2007:13:01:18 -0600] Started backend /usr/lib/cups/backend/socket (PID 11632) for job 262.
D [16/Nov/2007:13:01:18 -0600] Discarding unused job-state event...
D [16/Nov/2007:13:01:18 -0600] cupsdProcessIPPRequest: 7 status_code=0 (successful-ok)
E [16/Nov/2007:13:01:18 -0600] PID 11627 (/usr/lib/cups/filter/pstops) crashed on signal 11!
D [16/Nov/2007:13:01:18 -0600] [Job 262] Page = 612x792; 9,9 to 603,783
D [16/Nov/2007:13:01:18 -0600] [Job 262] slow_collate=0, slow_duplex=0, slow_order=1
D [16/Nov/2007:13:01:18 -0600] [Job 262] Before copy_comments - %!PS-Adobe-3.0
D [16/Nov/2007:13:01:18 -0600] [Job 262] %!PS-Adobe-3.0
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%Creator: GQview Version 2.0.2
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%CreationDate:
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%LanguageLevel 2
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%DocumentMedia:
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%Orientation: Portrait
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%BoundingBox: 0.000000 0.000000 612.000000 792.000000
E [16/Nov/2007:13:01:18 -0600] [Job 262] Bad %%BoundingBox: comment seen!
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%Pages: 1
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%PageOrder: Ascend
D [16/Nov/2007:13:01:18 -0600] [Job 262] %%Title:
D [16/Nov/2007:13:01:18 -0600] [Job 262] %% page 1
D [16/Nov/2007:13:01:18 -0600] [Job 262] Before copy_prolog - gsave
D [16/Nov/2007:13:01:18 -0600] [Job 262] Before copy_setup - DEBUG: Before page loop - INFO: Attempting to connect to host 192.168.1.102 on port 9100
D [16/Nov/2007:13:01:18 -0600] Discarding unused printer-state-changed event...
D [16/Nov/2007:13:01:18 -0600] cupsdCloseClient: 7
D [16/Nov/2007:13:01:18 -0600] Discarding unused printer-state-changed event...
D [16/Nov/2007:13:01:18 -0600] Discarding unused printer-state-changed event...
D [16/Nov/2007:13:01:18 -0600] [Job 262] Connected to 192.168.1.102:9100 (IPv4)...
D [16/Nov/2007:13:01:18 -0600] [Job 262] backendRunLoop(print_fd=0, device_fd=4, use_bc=1)
D [16/Nov/2007:13:01:21 -0600] [Job 262] Read 2567 bytes of print data...
D [16/Nov/2007:13:01:21 -0600] [Job 262] Wrote 2567 bytes of print data...
D [16/Nov/2007:13:01:22 -0600] [Job 262] Read 2 bytes of print data...
D [16/Nov/2007:13:01:22 -0600] [Job 262] Wrote 2 bytes of print data...
D [16/Nov/2007:13:01:22 -0600] [Job 262] *** glibc detected *** free(): invalid pointer: 0xb7f864f0 ***
D [16/Nov/2007:13:01:22 -0600] [Job 262] /usr/local/Brother/lpd/filterMFC5840CN: line 42: 13016 Done                    eval cat $INPUT_TEMP
D [16/Nov/2007:13:01:22 -0600] [Job 262] 13018                       | a2ps $A2PS_OP
D [16/Nov/2007:13:01:22 -0600] [Job 262] 13019                       | $PSCONV $PSCONV_OP
D [16/Nov/2007:13:01:22 -0600] [Job 262] 13020 Aborted                 | $BRCONV $BRCONV_OP
D [16/Nov/2007:13:01:22 -0600] Discarding unused printer-state-changed event...
D [16/Nov/2007:13:01:22 -0600] PID 11628 (/usr/lib/cups/filter/brlpdwrapperMFC5840CN) exited with no errors.
D [16/Nov/2007:13:01:22 -0600] Discarding unused printer-state-changed event...
D [16/Nov/2007:13:01:22 -0600] PID 11632 (/usr/lib/cups/backend/socket) exited with no errors.
D [16/Nov/2007:13:01:22 -0600] [Job 262] File 0 is complete.
D [16/Nov/2007:13:01:22 -0600] Discarding unused printer-state-changed event...
D [16/Nov/2007:13:01:22 -0600] Discarding unused job-stopped event...
D [16/Nov/2007:13:01:23 -0600] Unloading job 262...
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!