VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: no wpa_suppplicant.conf file  (Read 2453 times)

ds1

  • Member
  • *
  • Posts: 7
no wpa_suppplicant.conf file
« on: August 17, 2007, 12:58:57 am »

Hello

I am currently trying to follow the wireless how-to (very clearly written, thank you). Successfully completed up to and including step 3 but I'm stuck on the 'getting connected' bit. I'm trying to use wpa but I can't find wpa_supplicant.conf where it should be, or anywhere else for that matter.

I've tried creating wpa_supplicant.conf  myself as it's listed in the how-to but without $pairwise and $group as they gave me an 'unknown network' error message, but now when I type

wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

I get no output and still no connection. Could somebody advise me. please? Many thanks

Dave
Logged

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: no wpa_suppplicant.conf file
« Reply #1 on: August 17, 2007, 02:44:19 pm »

What kind of WPA connection are you trying to establish (whats the encryption type)?
Logged

ds1

  • Member
  • *
  • Posts: 7
Re: no wpa_suppplicant.conf file
« Reply #2 on: August 17, 2007, 03:10:07 pm »

My router is set to WPA-PSK TKIP, with WPA-802.1x as the other option.
Logged

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: no wpa_suppplicant.conf file
« Reply #3 on: August 20, 2007, 11:19:01 pm »

Could you try commenting out the first line of wpa_supplicant.conf, so it looks like this:

Code: [Select]
#ctrl_interface=/var/run/wpa_supplicant

network={
ssid="xxxxx"
key_mgmt=WPA-PSK
proto=WPA
#pairwise=TKIP CCMP
#group=TKIP
psk="xxxxxxx"
}

That line seems to cause problems for some people.
Logged

dh2k

  • Member
  • *
  • Posts: 8
Re: no wpa_suppplicant.conf file
« Reply #4 on: September 27, 2007, 10:36:11 am »

For my PCMCIA wifi card I am using the serialmonkey driver for RT61 chipset
http://prdownloads.sourceforge.net/rt2400/rt61-1.1.0-b2.tar.gz?download

After adding the module [rt61.ko] I can connect to an open network fine.

I have then created [/etc/wpa_supplicant.conf] as described in the readme files of the RT61 modules directory personalising the file with my wifi-network details and WPA details.

Then use:
Code: [Select]
wpa_supplicant -B -Dwext -ira0 -c/etc/wpa_supplicant.conf(ra0 is confirmed as my wireless interface via iwconfig)
But nothing, no connection.

How do I know what driver to use with wpa_supplicant as the [wpa_supplicant --help] help-files advise the wext is a generic driver?
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: no wpa_suppplicant.conf file
« Reply #5 on: September 27, 2007, 10:53:05 am »

For both my ndiswrapped acx111-chipset pci card and my native bcm43xx-chipset pcmcia card I use -Dwext and it works fine.  I also use wifi-rader to actually establish the connection.  My network is not broadcast, does not use dhcp, and uses WPA.  I create a wifi-rader profile with the ssid name, managed, auto channel, key left blank, wpa option left off [I DO use WPA], specify local ip, netmask, domain, dns1.

The way I typically start my wireless network is like this (from boot):
ifconfig wlan0 up
wpa_supplicant -Bw -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

Then I run wifi-radar and select my preconfigured profile and connect to it (of course adjust the interface name to match yours).
That's it.

HTH
Logged