VectorLinux
October 23, 2014, 12:21:04 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Skype not working, Assertion `!c->xlib.lock' failed  (Read 5854 times)
apock627
Member
*
Posts: 35


« on: August 18, 2007, 05:59:06 am »

Hi. Using VLSOHO 5.8, kernel 2.6.22.1
Trying to run skype for linux 1.4, have tried both static and dynamic executables.

Initially failed with error about libstdc++ and cxxlibs, fixed by downloading cxxlibs package and copying libstdc++ as suggested in a post somewhere, I've forgotten the details. This was the same as i had to do to get skype working with VLstandard 5.8 and it worked fine then.

Now skype fails with
Code:
skype: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted

whether starting as user or root.

Can anyone suggest a next step?
Thanks
Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #1 on: August 19, 2007, 01:08:23 am »

If you don't mind, you could use an older version of skype, 1.3.0.53, which is known to work in VL. The new skype uses a new version of qt which might cause those problems, not really sure though.
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
apock627
Member
*
Posts: 35


« Reply #2 on: August 20, 2007, 01:12:14 am »

Thanks, good suggestion.
BTW though the static version was working fine with VLstandard 5.8, but that doesn't mean there couldn't be a glitch with qt4 now.
Only problem now is I can't find any older versions to download. Even the pages titled skype for linux 1.3.0 etc have links that now point to version 1.4.
Anyone know where I could find an older version?
Thanks
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #3 on: August 20, 2007, 04:42:02 am »

Have you upgrade Xorg in your 5.8 install by any chance?... I've seen this error before on other applications, I think it's xorg related.
Logged

stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #4 on: August 20, 2007, 07:02:00 am »

BTW though the static version was working fine with VLstandard 5.8, but that doesn't mean there couldn't be a glitch with qt4 now.
It's possible that the qt4 was built against a different version of X. (Note: I have no idea how static packages work.)

I couldn't find one for download, so I just uploaded the one I have. You can download it here: http://www.fileden.com/files/2006/9/26/239698/skype-1.3.0.53-generic.tar.bz2
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #5 on: August 20, 2007, 09:44:40 am »

QT4 should be ok... I'm almost sure this problem is due to an xorg upgrade on the user's part... I've seen this before.
Logged

stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #6 on: August 20, 2007, 10:54:23 am »

QT4 should be ok... I'm almost sure this problem is due to an xorg upgrade on the user's part... I've seen this before.

It does appear that way...

I also found out the reason why the old skype binary isn't available for download. Skype-1.3.0.53 uses GIPS for the sound codec, and apparently, GIPS terminated the license and it can no longer distribute it. I might probably take down the download after a few days.
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
apock627
Member
*
Posts: 35


« Reply #7 on: August 21, 2007, 05:41:42 am »

Thanks to all and thanks esp. for upload, I have taken advantage but can't tell you if it works yet. Day has been to long already.

Apart from modifying xorg.conf for my synaptics touchpad I haven't mucked around with Xorg at all.
One thing I have mucked around with a lot is the kernel so there may well be a kernel config option to blame.

Will post back with 1.3.0 results.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #8 on: August 21, 2007, 05:51:19 am »

Apart from modifying xorg.conf for my synaptics touchpad I haven't mucked around with Xorg at all.

And you're sure this is SOHO 5.8, not SOHO 5.8.6RC1?
Logged

apock627
Member
*
Posts: 35


« Reply #9 on: August 21, 2007, 06:52:17 am »

My apologies, yes it is RC1.
I would rather not start with a new VL installation - is there something easily correctible?

skype 1.3.0.53 starts and can chat. Can't test sound yet.

Thanks
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #10 on: August 21, 2007, 07:47:57 am »

So it is indeed an xorg problem...
I think the xorg package that shipped with 5.8.6 is bad. I've built many after that, but not on a clean environment... so they're no good for you.

I am working on a new build... Hope to have it available by the end of the week.
Logged

apock627
Member
*
Posts: 35


« Reply #11 on: August 22, 2007, 04:47:05 am »

I've built xorg before when I was playing with linuxfromscratch but it's a bit of a stretch for me and I really don't have time right now. So if you're going to gift-wrap it for me i can only say........ Thanks!
Logged
apock627
Member
*
Posts: 35


« Reply #12 on: September 11, 2007, 06:55:56 am »

For anyone who finds this thread later, MOE-lnx's latest xorg-7.2 package fixes this problem. Thank you
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!