VectorLinux
April 24, 2014, 03:00:18 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: realtek nic found but no link  (Read 2098 times)
tomjoad
Member
*
Posts: 7


« on: August 28, 2007, 11:10:40 am »

Hello Canada,
VL5.8 can find but not use the realtek nic on my asus6rp. It's all abit strange since I belive it's quite standard.
The dmesg reports irq18, when I force the vasm to configure the card, ifconfig reports irq19.

Supplying dmesg, ifconfig, lsmod and lspci.

NIC (and cable) works with windows (dual boot) and it worked with xubuntu the other day.

(broadcom wlan doesn't work either but that's not really important right now.)

Thankful for any help!
/tj

***dmesg***
===========
Linux version 2.6.18.5 (root@vector.linux.net) (gcc version 3.4.6) #2 SMP PREEMPT Sat Dec 9 19:01:25 MST 2006
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000037fd0000 (usable)
 BIOS-e820: 0000000037fd0000 - 0000000037fde000 (ACPI data)
 BIOS-e820: 0000000037fde000 - 0000000038000000 (ACPI NVS)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ff780000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
895MB LOWMEM available.
On node 0 totalpages: 229328
  DMA zone: 4096 pages, LIFO batch:0
  Normal zone: 225232 pages, LIFO batch:31
DMI 2.3 present.
ACPI: RSDP (v000 ACPIAM                                ) @ 0x000f8290
ACPI: RSDT (v001 A M I  OEMRSDT  0x07000620 MSFT 0x00000097) @ 0x37fd0000
ACPI: FADT (v002 A M I  OEMFACP  0x07000620 MSFT 0x00000097) @ 0x37fd0200
ACPI: MADT (v001 A M I  OEMAPIC  0x07000620 MSFT 0x00000097) @ 0x37fd0390
ACPI: MCFG (v001 A M I  OEMMCFG  0x07000620 MSFT 0x00000097) @ 0x37fd03f0
ACPI: BOOT (v001 A M I  OEMBOOT  0x07000620 MSFT 0x00000097) @ 0x37fd0430
ACPI: OEMB (v001 A M I  AMI_OEM  0x07000620 MSFT 0x00000097) @ 0x37fde040
ACPI: HPET (v001 A M I  OEMHPET  0x07000620 MSFT 0x00000097) @ 0x37fd7150
ACPI: DSDT (v001  0AAAA 0AAAAB58 0x00000b58 INTL 0x02002026) @ 0x00000000
ATI board detected. Disabling timer routing over 8254.
ACPI: PM-Timer IO Port: 0x808
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Processor #0 6:14 APIC version 20
ACPI: LAPIC (acpi_id[0x02] lapic_id[0x81] disabled)
ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 1, version 33, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 21 low level)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
ACPI: HPET id: 0x0 base: 0xfed00000
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 40000000 (gap: 38000000:c6e00000)
Detected 1600.192 MHz processor.
Built 1 zonelists.  Total pages: 229328
Kernel command line: BOOT_IMAGE=linux ro root=304 hpet=disable
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 903732k/917312k available (3139k kernel code, 13080k reserved, 1229k data, 296k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 3385.95 BogoMIPS (lpj=1692978)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: afe9fbff 00100000 00000000 00000000 0000c109 00000000 00000000
CPU: After vendor identify, caps: afe9fbff 00100000 00000000 00000000 0000c109 00000000 00000000
monitor/mwait feature present.
using mwait in idle threads.
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: After all inits, caps: afe9fbff 00100000 00000000 00000940 0000c109 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 16k freed
ACPI: Core revision 20060707
CPU0: Intel(R) Celeron(R) M CPU        420  @ 1.60GHz stepping 08
Total of 1 processors activated (3385.95 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
Brought up 1 CPUs
migration_cost=0
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: BIOS Bug: MCFG area at e0000000 is not E820-reserved
PCI: Not using MMCONFIG.
PCI: PCI BIOS revision 3.00 entry at 0xf0031, last bus=3
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 0000:00:14.1
Boot video device is 0000:01:05.0
PCI: Transparent bridge - 0000:00:14.4
PCI: Bus #03 (-#06) is hidden behind transparent bridge #02 (-#03) (try 'pci=assign-busses')
Please report the result to linux-kernel to fix this permanently
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
ACPI: Embedded Controller [EC0] (gpe 24) interrupt mode.
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P9._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 9) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI: Cannot allocate resource region 3 of device 0000:00:00.0
PCI: Bridge: 0000:00:01.0
  IO window: 9000-9fff
  MEM window: fe100000-fe1fffff
  PREFETCH window: bdf00000-ddefffff
PCI: Bus 3, cardbus bridge: 0000:02:01.0
  IO window: 0000a000-0000a0ff
  IO window: 0000a400-0000a4ff
  PREFETCH window: 40000000-41ffffff
  MEM window: 42000000-43ffffff
PCI: Bridge: 0000:00:14.4
  IO window: a000-bfff
  MEM window: fe200000-feafffff
  PREFETCH window: ddf00000-dfefffff
ACPI: PCI Interrupt 0000:02:01.0[A] -> GSI 16 (level, low) -> IRQ 16
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1572864 bytes)
TCP bind hash table entries: 65536 (order: 7, 786432 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
Simple Boot Flag at 0xff set to 0x1
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: overridden by ACPI.
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SGI XFS with ACLs, security attributes, large block numbers, no debug enabled
SGI XFS Quota Management subsystem
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI: AC Adapter [AC0] (on-line)
ACPI: Battery Slot [BAT0] (battery present)
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Processor [CPU1] (supports 8 throttling states)
ACPI: Getting cpuindex for acpiid 0x2
ACPI: Thermal Zone [THRM] (46 C)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12ac
Linux agpgart interface v0.101 (c) Dave Jones
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
floppy0: no floppy controllers found
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ATIIXP: IDE controller at PCI slot 0000:00:14.1
ACPI: PCI Interrupt 0000:00:14.1[A] -> GSI 16 (level, low) -> IRQ 16
ATIIXP: chipset revision 128
ATIIXP: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdc:pio, hdd:DMA
Probing IDE interface ide0...
hda: ST98823A, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdd: MATSHITADVD-RAM UJ-850S, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 512KiB
hda: 156301488 sectors (80026 MB) w/8192KiB Cache, CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
 hda: hda1 hda2 hda3 < hda5 hda6 > hda4
hdd: ATAPI 24X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
Loading Adaptec I2O RAID: Version 2.4 Build 5go
Detecting Adaptec I2O RAID controllers...
Adaptec aacraid driver (1.1-5[2409]-mh2)
scsi: <fdomain> Detection failed (no card)
NCR53c406a: no available ports found
sym53c416.c: Version 1.0.0-ac
qlogicfas: no cards were found, please specify I/O address and IRQ using iobase= and irq= optionsFailed initialization of WD-7000 SCSI card!
megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
megaraid: 2.20.4.9 (Release Date: Sun Jul 16 12:27:22 EST 2006)
megasas: 00.00.03.01 Sun May 14 22:49:52 PDT 2006
GDT-HA: Storage RAID Controller Driver. Version: 3.05
GDT-HA: Found 0 PCI Storage RAID Controllers
3ware Storage Controller device driver for Linux v1.26.02.001.
3ware 9000 Storage Controller device driver for Linux v2.26.02.007.
nsp32: loading...
ipr: IBM Power RAID SCSI Device Driver version: 2.1.3 (March 29, 2006)
libata version 2.00 loaded.
RocketRAID 3xxx SATA Controller driver v1.0 (060426)
st: Version 20050830, fixed bufsize 32768, s/g segs 256
usbmon: debugfs is not available
ACPI: PCI Interrupt 0000:00:13.2[A] -> GSI 19 (level, low) -> IRQ 17
ehci_hcd 0000:00:13.2: EHCI Host Controller
ehci_hcd 0000:00:13.2: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:13.2: irq 17, io mem 0xfebfd000
ehci_hcd 0000:00:13.2: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt 0000:00:13.0[A] -> GSI 19 (level, low) -> IRQ 17
ohci_hcd 0000:00:13.0: OHCI Host Controller
ohci_hcd 0000:00:13.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:13.0: irq 17, io mem 0xfebff000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 4 ports detected
ACPI: PCI Interrupt 0000:00:13.1[A] -> GSI 19 (level, low) -> IRQ 17
ohci_hcd 0000:00:13.1: OHCI Host Controller
ohci_hcd 0000:00:13.1: new USB bus registered, assigned bus number 3
ohci_hcd 0000:00:13.1: irq 17, io mem 0xfebfe000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 4 ports detected
USB Universal Host Controller Interface driver v3.0
sl811: driver sl811-hcd, 19 May 2005
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
PNP: No PS/2 controller found. Probing ports directly.
i8042.c: Detected active multiplexing controller, rev 1.1.
serio: i8042 AUX0 port at 0x60,0x64 irq 12
serio: i8042 AUX1 port at 0x60,0x64 irq 12
serio: i8042 AUX2 port at 0x60,0x64 irq 12
serio: i8042 AUX3 port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI Shortcut mode
Time: tsc clocksource has been installed.
Time: acpi_pm clocksource has been installed.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 296k freed
input: AT Translated Set 2 keyboard as /class/input/input0
Synaptics Touchpad, model: 1, fw: 6.1, id: 0xa3a0b3, caps: 0xa04713/0x10008
input: SynPS/2 Synaptics TouchPad as /class/input/input1
EXT3 FS on hda4, internal journal
Adding 1020088k swap on /dev/hda6.  Priority:-1 extents:1 across:1020088k
input: PC Speaker as /class/input/input2
Yenta: CardBus bridge found at 0000:02:01.0 [1043:1397]
Yenta: ISA IRQ mask 0x06b8, PCI irq 16
Socket status: 30000006
Yenta: Raising subordinate bus# of parent bus (#02) from #03 to #06
pcmcia: parent PCI bridge I/O window: 0xa000 - 0xbfff
cs: IO port probe 0xa000-0xbfff: clean.
pcmcia: parent PCI bridge Memory window: 0xfe200000 - 0xfeafffff
pcmcia: parent PCI bridge Memory window: 0xddf00000 - 0xdfefffff
8139too Fast Ethernet driver 0.9.27
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 20 (level, low) -> IRQ 18
eth0: RealTek RTL8139 at 0xb800, 00:18:f3:45:e0:c3, IRQ 18
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
ieee80211_crypt: registered algorithm 'NULL'
piix4_smbus 0000:00:14.0: Found 0000:00:14.0 device
ACPI: PCI Interrupt 0000:00:14.2[A] -> GSI 16 (level, low) -> IRQ 16
hda_codec: Unknown model for ALC861, trying auto-probe from BIOS...
sdhci: Secure Digital Host Controller Interface driver, 0.12
sdhci: Copyright(c) Pierre Ossman
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
bcm43xx driver
sdhci: SDHCI controller found at 0000:02:01.1 [1180:0822] (rev 17)
ACPI: PCI Interrupt 0000:02:01.1[C] -> GSI 18 (level, low) -> IRQ 19
mmc0: SDHCI at 0xfeaff800 irq 19 DMA
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
ACPI: PCI Interrupt 0000:02:03.0[A] -> GSI 22 (level, low) -> IRQ 20
bcm43xx: Chip ID 0x4318, rev 0x2
bcm43xx: Number of cores: 4
bcm43xx: Core 0: ID 0x800, rev 0xd, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x9, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x804, rev 0xc, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x80d, rev 0x7, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 3, Type 2, Revision 7
bcm43xx: Detected Radio: ID: 8205017f (Manuf: 17f Ver: 2050 Rev: Cool
bcm43xx: Radio turned off
bcm43xx: Radio turned off
cs: IO port probe 0xc00-0xcff: excluding 0xc00-0xc07 0xc10-0xc17 0xc50-0xc57 0xc68-0xc6f 0xcd0-0xcdf
cs: IO port probe 0x820-0x8ff: excluding 0x830-0x837
cs: IO port probe 0x800-0x80f: clean.
cs: IO port probe 0x3e0-0x4ff: excluding 0x408-0x40f 0x4d0-0x4d7
cs: IO port probe 0x100-0x3af: excluding 0x378-0x37f
cs: IO port probe 0xa00-0xaff: excluding 0xa00-0xa0f
fuse init (API version 7.Cool
fuse distribution version: 2.6.1
powernow: This module only works with AMD K7 CPUs
p4-clockmod: Unknown p4-clockmod-capable CPU. Please send an e-mail to <linux@brodo.de>
ip_tables: (C) 2000-2006 Netfilter Core Team
ip_conntrack version 2.4 (7166 buckets, 57328 max) - 224 bytes per conntrack
eth0: link down
eth0: link down

***ifconfig***
===========
eth0      Link encap:Ethernet  HWaddr 00:18:F3:45:E0:C3 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18 Base address:0xb800

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:200 (200.0 b)  TX bytes:200 (200.0 b)



***lsmod***
Module                  Size  Used by
xt_limit                3200  0
xt_pkttype              2688  0
ipt_REJECT              4864  0
xt_tcpudp               3968  0
ipt_LOG                 6144  0
xt_state                2816  0
iptable_mangle          3200  0
iptable_nat             6660  0
iptable_filter          3328  0
ip_conntrack_irc        6128  0
ip_nat_ftp              3584  0
ip_nat                 13868  2 iptable_nat,ip_nat_ftp
ip_conntrack_ftp        6640  1 ip_nat_ftp
ip_conntrack           37600  6 xt_state,iptable_nat,ip_conntrack_irc,ip_nat_ftp,ip_nat,ip_conntrack_ftp
ip_tables              12020  3 iptable_mangle,iptable_nat,iptable_filter
x_tables               11140  8 xt_limit,xt_pkttype,ipt_REJECT,xt_tcpudp,ipt_LOG,xt_state,iptable_nat,ip_tables
cpufreq_conservative     6536  0
cpufreq_ondemand        5900  0
cpufreq_performance     2816  0
cpufreq_powersave       2560  0
speedstep_lib           4740  0
freq_table              4512  0
sg                     25500  0
fuse                   37780  0
snd_seq_dummy           3716  0
snd_seq_oss            27392  0
snd_seq_midi_event      6528  1 snd_seq_oss
snd_seq                42320  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          6924  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37280  0
snd_mixer_oss          14080  3 snd_pcm_oss
bcm43xx               401952  0
ieee80211softmac       24064  1 bcm43xx
ieee80211              27080  2 bcm43xx,ieee80211softmac
pcmcia                 22560  0
sdhci                  14988  0
shpchp                 29604  0
joydev                  8512  0
evdev                   8320  0
snd_hda_intel          14868  2
snd_hda_codec         138416  1 snd_hda_intel
i2c_piix4               8076  0
ieee80211_crypt         5504  1 ieee80211
mmc_core               18432  1 sdhci
8139too                22016  0
snd_pcm                61828  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              18692  2 snd_seq,snd_pcm
snd                    39780  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore               8032  3 snd
i2c_core               16256  1 i2c_piix4
yenta_socket           22156  1
rsrc_nonstatic         10624  1 yenta_socket
pcmcia_core            31512  3 pcmcia,yenta_socket,rsrc_nonstatic
snd_page_alloc          8072  2 snd_hda_intel,snd_pcm
mii                     5376  1 8139too
ati_agp                 7436  0
serio_raw               6148  0
pcspkr                  3456  0



***lspci***
00:00.0 Host bridge: ATI Technologies Inc Unknown device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI (rev 80)
00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
02:01.1 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
02:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)
02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #1 on: August 28, 2007, 11:36:37 am »

We're not all from Canada, just a small handful in fact, most of us are quite "international", but hello anyways. I see nothing wrong with lsmod and lspci but dmesg says "eth0 down". That is strange. Are you absolutely positive you have your cabling between your PC-modem-router all OK? If you are on a cable modem shut down the Linux box, unplug the cable modem, give it a few seconds, plug it in again and retry. Can't suggest anything else at the moment...
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
tomjoad
Member
*
Posts: 7


« Reply #2 on: August 28, 2007, 11:44:54 am »

Hello and thank you for a quick reply,
(I sure understand that all vl-users are not
from canada but now and then I excited
by the speed of the net. It may be quite naive,
but still, Afganistan, Tokyo, Melburne and Reykavik,
hello even to you!)

Anyway,
I'm positive the connector and cable are fine,
booting XP (without any fiddeling with the cables
works fine, also at 100 mbps).

However, I disabled the acpi from lilo and got
some form of success.
dmesg now reports link up at 100 mbps,
but still no luck with getting an ip to work.

during vasm/network/start network..
ifconfig displays both eth0 and lo,
(during trying to get an ip from dhcpd)
then eth0 goes away...

irq changed from 18/19 or whatever to 4.

my pc is connected to a netgear router, working as a dhcpd.
Nothing on the routers indicates any form of connection with
the nic under linux. (which makes sense since ifconfig reports
eth0/tx=0 packages)

Does anybody else use asus notebooks?

thank you!
/tj
« Last Edit: August 28, 2007, 12:01:15 pm by tomjoad » Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #3 on: August 28, 2007, 02:59:29 pm »

OK. Post the output of the following commands:

cat /etc/rc.d/rc.inet1
cat /etc/resolv.conf
route -n

Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
tomjoad
Member
*
Posts: 7


« Reply #4 on: August 29, 2007, 04:39:45 am »

Hello lagagnon,

Suddenly the net works. Strange and a bit embarrassing. Guess posting the /etc-files
doesn't matter right now. I'll come back if the problem persists.

(I do recall that the eth0/eth1 was swapped on boot yesterday, even after disabling
apci, eth0=broadcom, eth1=realtek. Now eth0=realtek.)

Thank you for a good distribution, have used it on a -98 fsc lifebook for years with
very good result.

All the best,
//t
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #5 on: August 29, 2007, 05:34:34 am »

This howto by Joe1962 will solve your problem, it is a must for anyone with more than one network device: http://www.vectorlinux.com/forum2/index.php?topic=979.0
cheers, Rodrigo
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
tomjoad
Member
*
Posts: 7


« Reply #6 on: August 29, 2007, 11:29:56 am »

Thank You!
Just discovered what's been goin'on. The realtek have for every reboot
been pending to be either eth0 or eth1. Drove me nuts with having to
vasm/network/inet after every reboot.

Still, apci is turned off. Would like to use it though, in my previous post
dmesg outputs a different irq than ifconfig. Is that the issue or shall I
just forget acpi?

Thank you!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!