VectorLinux
August 30, 2014, 06:09:32 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Manually Mounting LaCie USB Device  (Read 3498 times)
Miki Tebeka
Member
*
Posts: 27



WWW
« on: August 22, 2007, 04:56:19 pm »

Hello All,

I've connected a LaCie usb device (http://www.lacie.com/us/index.htm) to my box (VL standard 5.Cool.
The system identifies the drive:
Code:
mtebeka@bugs:~ - 17:52 $ sudo /sbin/lsusb
Bus 4 Device 1: ID 0000:0000 
Bus 5 Device 1: ID 0000:0000 
Bus 3 Device 1: ID 0000:0000 
Bus 1 Device 6: ID 059f:0526 LaCie, Ltd
Bus 1 Device 1: ID 0000:0000 
Bus 2 Device 1: ID 0000:0000 
Bus 2 Device 3: ID 046d:c016 Logitech, Inc. M-UV69a Optical Wheel Mouse
Bus 2 Device 2: ID 0853:0100 

However I don't know how to mount the USB volume.
Code:
mtebeka@bugs:~ - 17:54 $ sudo mount -t autofs /dev/usbdev1.6 /mnt/usb/
mount: wrong fs type, bad option, bad superblock on /dev/usbdev1.6,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Any ideas?

Thanks,
Miki
Logged

lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #1 on: August 22, 2007, 06:11:59 pm »

Miki: vl-hot and udev should have already mounted that device for you within a couple of seconds of you plugging it in. Navigate to /mnt/vl-hot and it should be listed there somewhere... I think !
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Miki Tebeka
Member
*
Posts: 27



WWW
« Reply #2 on: August 23, 2007, 05:46:30 am »

No /mnt/vl-hot Sad

How can I enable vl-hot?
Logged

Miki Tebeka
Member
*
Posts: 27



WWW
« Reply #3 on: August 23, 2007, 06:04:16 am »

Some more information:

Code:
mtebeka@bugs:linux - 07:01 $ sudo /sbin/fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1           60740       60801      498015   82  Linux swap
/dev/sda2   *           1       60739   487885986   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       60801   488384001   83  Linux

Disk /dev/sdc: 2000.4 GB, 2000431349760 bytes
255 heads, 63 sectors/track, 243205 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System

/dev/sdc looks like it's the LaCie drive. However when I try to mount I get the same error:
Code:
mtebeka@bugs:linux - 07:03 $ sudo mount -t autofs /dev/sdc /mnt/usb/
mount: wrong fs type, bad option, bad superblock on /dev/sdc,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
Logged

stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #4 on: August 23, 2007, 10:37:12 am »

From the fdisk output, it doesn't seem to be formatted... (no partitions). Have you used it on other computers before?
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
Miki Tebeka
Member
*
Posts: 27



WWW
« Reply #5 on: August 23, 2007, 11:07:15 am »

Yes, I can view it clearly from a Mac.
Logged

The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1545


I like the bass to go BOOM!


WWW
« Reply #6 on: August 23, 2007, 01:04:27 pm »

Try mounting without the -t autofs option, or with the correct filesystem type. What type of filesystem is on that drive?
Logged

Most music on my soundcloud page was arranged in programs running on VL.
Miki Tebeka
Member
*
Posts: 27



WWW
« Reply #7 on: August 23, 2007, 01:36:26 pm »

I wish I knew the file system type Smiley

Trying to mount without fs type gives an error:
Code:
mtebeka@bugs:~ - 14:35 $ sudo mount /dev/sdc /mnt/usb/
mount: you must specify the filesystem type
mtebeka@bugs:~ - 14:35 $ echo $?
32
Logged

uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #8 on: August 23, 2007, 02:10:08 pm »

try parted
parted /dev/sdc print

hopefully it will tell you what the partition format is
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4022



« Reply #9 on: August 23, 2007, 08:20:08 pm »

Code:
mtebeka@bugs:~ - 14:35 $ sudo mount /dev/sdc /mnt/usb/
mount: you must specify the filesystem type

You would need to specify a partition, like /dev/sdc1
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2282


« Reply #10 on: August 24, 2007, 06:15:21 am »

Perhaps the filesystem is HFS+?
You could try mount -t hfsplus /dev/sdc1 /mnt/usb

I dont know if the vl kernel has the hfs+ support compiled though Huh
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #11 on: August 24, 2007, 10:11:44 am »

Perhaps the filesystem is HFS+?
You could try mount -t hfsplus /dev/sdc1 /mnt/usb
That is what the mac uses and according to google, it doesn't show up in fdisk so that's probably it.

Quote
I dont know if the vl kernel has the hfs+ support compiled though Huh

It's compiled as a module so you may need to do a "modprobe hfsplus"
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!