VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: How do I disable the touchpad and keep the "real" mouse?  (Read 3453 times)

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
How do I disable the touchpad and keep the "real" mouse?
« on: August 23, 2007, 09:22:38 pm »

Running VL 5.8 Standard on my new laptop, I have both the touchpad and a USB mouse working. The touchpad is driving me crazy. If I hover over it, the cursor is likely to move. I want to disable the touchpad and use just the USB mouse.

I ran into the same situation when I first installed VL 5.8 Standard on my now fatally ill old laptop and someone posted a solution (Joe1962, I think). I couldn't find that message--it was probably lost in the forum changes.

Please tell me how to make the USB mouse the only pointing device.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #1 on: August 23, 2007, 10:24:53 pm »

someone posted a solution (Joe1962, I think).
Yes, I have a vague recollection of that... :-\

I couldn't find that message--it was probably lost in the forum changes.
I'd say that's pretty certain... ::)

Please tell me how to make the USB mouse the only pointing device.
A quick, off the cuff idea is that AFAIK, touchpads are PS2 devices, so blacklisting the PS2 module might work. Sorry I don't have my VL setup working yet, so I can't be more specific, nor even test it.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

stoichyu

  • Packager
  • Vectorite
  • ****
  • Posts: 369
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #2 on: August 23, 2007, 11:45:34 pm »

I think it had something to do with xorg.conf, how many mice are specified there?
Logged
There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1300
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #3 on: August 24, 2007, 04:33:56 am »

Granny, this may be your ticket. http://www.compass.com/synaptics/

tpconfig supposedly will allow you to disable the touchpad at startup. :)
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #4 on: August 24, 2007, 08:12:17 am »

GrannyGeek: some laptops have a small button above the touchpad so you can turn it off in hardware - perhaps not on your machine?
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #5 on: August 24, 2007, 07:16:26 pm »

There is no hardware switch or function key combination for turning off the touchpad. Stoichyu is right--there was some edit in xorg.conf and I think something in /dev. Currently, the mouse lines in xorg.conf are:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/mouse"
    Option         "ZAxisMapping" "4 5"
EndSection


Mouse0 is the USB mouse. /dev/mouse is a symlink to /dev/input/mice. That contains event0, event1, event2, event3, mice, mouse0, mouse1. The touchpad is mouse1.

I think the old solution involved a symlink to something and maybe a change from "Protocol" "auto" to something else. Does this ring any bells? I'd like to avoid tpconfig if possible.

I read quite a few messages in this that were turned up in a Google search, but none of the suggested solutions matched what I have in xorg.conf.

I hope in the future we can have a failsafe way to back up the entire message board. We've lost some crucial information every time some evil has befallen the board.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

stoichyu

  • Packager
  • Vectorite
  • ****
  • Posts: 369
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #6 on: August 25, 2007, 03:58:28 am »

Have you tried changing Device to /dev/input/mouse0? You could also try IMPS/2 for the protocol.
Logged
There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #7 on: August 25, 2007, 05:18:59 pm »

Have you tried changing Device to /dev/input/mouse0? You could also try IMPS/2 for the protocol.

Thank you, thank you! That did it. Now I have the mouse and no touchpad. Life is good!
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4088
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #8 on: September 22, 2007, 11:16:23 am »

I remembered this thread when I came across this little howto:
http://www.lockergnome.com/nexus/linux/2007/09/20/disable-your-notebook-touchpad-the-easy-way

- Just in case it can be of help to others down the road -
Logged

stoichyu

  • Packager
  • Vectorite
  • ****
  • Posts: 369
Re: How do I disable the touchpad and keep the "real" mouse?
« Reply #9 on: September 23, 2007, 08:54:19 am »

That certainly provides a nice solution to the touchpad problem. And it'd work on any touchpad too. I tried "rmmod psmouse" and the touchpad stopped. However, when I re-enabled it with "modprobe psmouse", I had the touchpad back, but my scrolling was lost. But if you just want to disable the touchpad permanently, I guess it's not a problem.
Logged
There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836