VectorLinux
November 24, 2014, 12:00:01 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Module pygtk not found [SOLVED]  (Read 2699 times)
gijii
Member
*
Posts: 28


« on: August 25, 2007, 08:03:44 am »

Hi all,

I am trying to make work Devede, a nice program to make dvd's.
This is the link to the program:
www.rastersoft.com/programas/devede.html
The program is written in python and the package does not contain any "configure" script and cannot be compiled as usual.
To install it it is necessary to run the "install.sh" script.
I did it and the program now appears in the "multimedia" menu but, unfortunately, it does not work.
Starting the program through a shell command returns a message similar to "Module pygtk not found".
The pygtk package is actually installed so I am not able to find a solution to this issue.
I tried installing/updating any package connected to python but I was not successful.
I do not know anything regarding python.
Can anyone help me to find a solution to this problem?

Thanks in advance.

Gijii
« Last Edit: August 29, 2007, 07:05:39 am by gijii » Logged

Vectorlinux Soho 5.8, Kernel 2.6.21-ck2. AMD Athlon XP 2.4, 1 GB ram, 320 Gb HD
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #1 on: August 25, 2007, 08:13:52 am »

You already have a thread on the subject and a package has been prepared:
http://www.vectorlinux.com/forum2/index.php?topic=4059.0

It should be up on the repo soon.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #2 on: August 25, 2007, 10:25:34 am »

I wonder why the hell it can't import pygtk...
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #3 on: August 25, 2007, 12:21:46 pm »

i have had that same error when pycairo was missing
Logged
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #4 on: August 25, 2007, 03:19:08 pm »

I've had that error before in the past.  I don't know exactly how I resolved it.  I think it was pycairo related as well.
Logged
gijii
Member
*
Posts: 28


« Reply #5 on: August 25, 2007, 11:21:04 pm »

Sorry, I did not want to make double posts on the same topic. That thread was to request the package, since I believe it would be a good application for Vector repo.
Meantime I was trying to make it work (thanks to everybody for being so quick in accepting my suggestion and preparing the package).
Unfortunately my knowledge of Python is really low and so I was unable to track the problem down.
Pycairo is installed. I encountered the same problem before and I installed pycairo and various other packages related to python, included pygtk.

Thanks
Logged

Vectorlinux Soho 5.8, Kernel 2.6.21-ck2. AMD Athlon XP 2.4, 1 GB ram, 320 Gb HD
gijii
Member
*
Posts: 28


« Reply #6 on: August 26, 2007, 02:59:15 am »

Maybe I found the solution.
There are two packages named pygtk.
Pygtk version 2.8.6-i586-4vl58 (gtk Python wrappers)
Pygtk version 2.10.4-i586-4vl58
I installed the second package because I believed it was the same package in the most recent version.
I removed it and I installed the other and now Devede starts.
I have not yet tried it but I will do it soon.


Cheers

Gijii
« Last Edit: August 29, 2007, 07:05:01 am by gijii » Logged

Vectorlinux Soho 5.8, Kernel 2.6.21-ck2. AMD Athlon XP 2.4, 1 GB ram, 320 Gb HD
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!