VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Getting Chestnut (0.3.2) to connect  (Read 2433 times)

foxinsocks

  • Member
  • *
  • Posts: 5
Getting Chestnut (0.3.2) to connect
« on: September 02, 2007, 05:29:52 pm »

Running Vector Linux 5.8-RC1 (yeah, I know... ) kernel 2.6.17.13 on my Dell Latitude CPx H laptop.
There's probably a trivial solution to my problem, but I keep getting the message "Failed to open /dev/ttys0: Permission denied." What to do? It would seem that there's a config file somewhere that needs tickilng, but which one -  and where? Any help would be appreciated. I'm not a linux-noob, just haven't played with VL before.
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Getting Chestnut (0.3.2) to connect
« Reply #1 on: September 02, 2007, 06:21:56 pm »

The tty* device is accesible by root only, so you can use chesnut as root. You need to add yourself to the tty group to use chesnut as user. To do that you have two options:
Run in a terminal the id command. It will give you an output with something like "groups=..." and then a list with all the groups you are member. Then as root, run the usermod command like this: usermod -G <list of all the groups you are member separated with commas and no spaces>,tty <username>
Add the tty group at the end of the list, then space and then your username. In my machine that would be something like
Code: [Select]
root:$ usermod -G lp,floppy,audio,video,cdrom,games,scanner,tty rbistolfiThat list can be different on your box. Be sure you use a capitol G as an option, and check the list twice ;)

The other way is editing the /etc/group file as root. Find the line looking like tty::5: and replace it with tty::5:<your_username> Mine looks tty::5:rbistolfi with no spaces. If you want to add more than one user just use a comma and no spaces, like tty::5:rbistolfi,melina,vanesa
Be sure you are not editing anything but that line. Save the file and login with your acount again and you should be able to use chestnut-dialer as user.
« Last Edit: September 02, 2007, 07:15:56 pm by rbistolfi »
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

foxinsocks

  • Member
  • *
  • Posts: 5
Re: Getting Chestnut (0.3.2) to connect
« Reply #2 on: September 03, 2007, 04:32:36 am »

Thanks for the help; this reply is coming via the 'VL5.8 laptop'.  ;D  Chestnut-dialer worked a treat.
I'm not sure but I think some of my earlier problems related to a screwy network configuration. I did a quick reinstall without the network card - Just a 'plain vanilla' stand-alone laptop connected to dial-up. Now that I know how to set up the dialer successfully, I can gradually play around with getting this machine networked again with my desktop box.
Cheers.
Logged