VectorLinux
September 22, 2014, 09:52:53 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [SOLVED] Unable to change mime-type association  (Read 3234 times)
Miki Tebeka
Member
*
Posts: 27



WWW
« on: August 27, 2007, 01:05:03 pm »

Hello All,

Trying to make acroread the default PDF handler...

I've move xpdf.desktop from /usr/share/applications, (AdobeReader.desktop is there).
Ran update-mime-data /usr/share/mime

However when I run exo-open ~/eBooks/abs-guide.pdf, I still get xpdf.

Any ideas?

Thanks!
--
Miki <miki.tebeka@gmail.com>
http://pythonwise.blogspot.com
« Last Edit: August 30, 2007, 05:51:03 am by Miki Tebeka » Logged

wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: August 28, 2007, 05:24:05 am »

I'm guessing you could just right-click on the pdf file in Thunar, and choose to open the file with xpdf, checking the box to make it the default. Would this work?
Logged
Miki Tebeka
Member
*
Posts: 27



WWW
« Reply #2 on: August 29, 2007, 07:31:23 am »

Yup, this did the trick.
Thanks!

However, I'm a shell kind of guy. Where does exo-open gets the mime type association?
Logged

wcs
Packager
Vectorian
****
Posts: 1144


« Reply #3 on: August 29, 2007, 07:55:54 am »

Quote
Where does exo-open gets the mime type association?

I really don't know... If using exo-open, I change the preferred application in Thunar.
Maybe someone else will jump in at this point.
Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #4 on: August 29, 2007, 10:37:31 am »

exo-open seems to use ~/.local/share/applications/default.list according to http://foo-projects.org/pipermail/xfce/2006-August/018439.html

Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #5 on: August 29, 2007, 05:37:58 pm »

That makes sense!... I was wondering why I couldn't find it in /usr/share somewhere, but of course it would be inside an user's home directory.
Sure enough, it does list the Thunar preferences in order.
Logged
Miki Tebeka
Member
*
Posts: 27



WWW
« Reply #6 on: August 30, 2007, 05:47:20 am »

exo-open seems to use ~/.local/share/applications/default.list according to http://foo-projects.org/pipermail/xfce/2006-August/018439.html


Excellent, just what I wanted.
Thanks!
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!