VectorLinux
September 19, 2014, 01:35:47 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: How to get laptop speakers to work with alsa  (Read 11290 times)
apock627
Member
*
Posts: 35


« Reply #15 on: September 01, 2007, 12:11:44 am »

Well maybe I can't load it at boot. I thought it would be obvious how the sound modules got loaded but it isn't to me.
I've edited any files containing snd_hda_intel as follows:

root:# grep -r intel /etc | grep snd
/etc/rc.d/rc.modules:/sbin/modprobe snd_hda_intel model=basic
/etc/modprobe.d/sound:alias snd-card-0 "snd-hda-intel model=basic"
/etc/modprobe.d/sound:alias sound-slot-0 "snd-hda-intel model=basic"

but the module is still getting loaded without the model=basic option.

Does anyone know the right way to do this?
Thanks
Logged
gamfa
Vectorite
***
Posts: 245



« Reply #16 on: September 01, 2007, 06:26:20 am »

I have been playing with this problem on my Toshiba A135. I have had no luck at all with the standard install of 5.8. I have had a little luck on a fresh install. On that partition I downloaded and installed the 2.6.21.5 kertnel from the repository and here is what I am getting in GAmix on that paration....

edit...I tried to insert an image here but was not able to get it to work...sorry

Now I am getting an error msg. something like...

"unable to find simple control: 'pcm':0"

Any suggestions???

By the way. I did not load the snd_hda_intel module here with the "model=" addition. It identified the card itself. What is a bit strange about this is that the sound works in Grafpup using a 2.6.20.2 kernel.
« Last Edit: September 01, 2007, 07:02:32 am by gamfa » Logged

"Don't tell my cattle I have leather seats in my truck"

"I never let schooling stand in the way of my education"...Mark Twain
apock627
Member
*
Posts: 35


« Reply #17 on: September 08, 2007, 09:41:35 pm »

Gave up on finding the right way to get this started and wrote a script to run after boot to rm the module and re-insert it with the model=basic option. But now I have it working the right way so I thought i'd share in case I'm not the only person who doesn't know this.

To the file /etc/modprobe.d/sound
add the line
options snd_hda_intel model=basic

I added it at the beginning and it works, not sure if that is crucial.
Obviously replace basic with your model.
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!