Author Topic: VL 7.1 STD B3 ready for testing  (Read 48006 times)

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3286
  • -- Just being myself --
Re: VL 7.1 STD B3 ready for testing
« Reply #75 on: June 04, 2014, 11:40:20 pm »
Just saw there is another GnuTLS security issue so I build GnuTLS-3.2.15 for VL 7.1...maybe some pls check it out

http://arstechnica.com/security/2014/06/critical-new-bug-in-crypto-library-leaves-linux-apps-open-to-drive-by-attacks/

roarde

  • Vectorian
  • ****
  • Posts: 781
  • it's enough
Re: VL 7.1 STD B3 ready for testing
« Reply #76 on: June 04, 2014, 11:54:24 pm »
GnuTLS:
Just installed it, then thrashed it around a little bit running HexChat with SSL connection and Firefox with the HTTPS Everywhere plugin going. Everything works well, will let you know if that changes.
Robert

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3286
  • -- Just being myself --
Re: VL 7.1 STD B3 ready for testing
« Reply #77 on: June 06, 2014, 04:06:43 am »
Another OpenSSL security bugs...i can try to build after next monday...but if someone free can build it first :P

http://www.zdnet.com/openssl-fixes-another-severe-vulnerability-7000030253/

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3497
Re: VL 7.1 STD B3 ready for testing
« Reply #78 on: June 06, 2014, 10:09:59 am »
Security update has been done on 7.1
http://vlcore.vectorlinux.com/buildbot/builders/openssl/builds/13

I don't know what kind of ramifications we can expect from upgrading openssl on 7.0.  It is currently at 0.9.8x there, so I wont touch it for now because I don't know if it will break other things

roarde

  • Vectorian
  • ****
  • Posts: 781
  • it's enough
Re: VL 7.1 STD B3 ready for testing
« Reply #79 on: June 06, 2014, 08:09:39 pm »
Somehow, I have a 7.0 with 1.0.0g, 18 Jan 2012.

Examining further, 1.0.0g and 1.0.0d are in extra. No idea why in extra.

But looking at vabs, no real idea how they got there. A scan of the SlackBuild did turn up a line that might patch later versions to report 0.9.8 to some software, not sure.

BTW: repo maintenance or slow scripts temporarily blocked upgrading on 7.1. If you tried prior to the "last edit" time of this post, try again. Seems to work now.
« Last Edit: June 06, 2014, 08:57:42 pm by roarde »
Robert