VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: GTK+ 2.10.14  (Read 2754 times)

Dweeberkitty

  • Packager
  • Vectorian
  • ****
  • Posts: 836
    • Multimedia Bonus Disc
GTK+ 2.10.14
« on: September 09, 2007, 10:09:14 pm »

Hey! Could someone package the latest GTK+? The next version of the Gimp is just about ready to come out and it requires GTK+ >= 2.10.13. Also I believe that pangocairo needs to be compiled in. It would be nice to have this ready before Gimp 2.4 comes out so that it will be really easy to upgrade to the next sweet version. I don't have time to compile this right now so could someone do it for me? Thanks!
Logged
Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: GTK+ 2.10.14
« Reply #1 on: September 10, 2007, 12:18:19 am »

Last time the gtk2  on 5.8 was upgraded dependency hell was unleashed. I really don't like the idea of anyone trying to replace the default Slack gtk2 package, as it goes wrong time and time again. IMO there is no app (not even the gimp) that justifies this.
Logged
Most music on my soundcloud page was arranged in programs running on VL.

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: GTK+ 2.10.14
« Reply #2 on: September 10, 2007, 04:01:07 am »

Maybe it's time for an unsupported repo... ;)
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

Dweeberkitty

  • Packager
  • Vectorian
  • ****
  • Posts: 836
    • Multimedia Bonus Disc
Re: GTK+ 2.10.14
« Reply #3 on: September 11, 2007, 09:00:18 pm »

Could someone build it for VL 5.9? I think 5.9 should have all the gtk apps built against the latest version of gtk anyway.
Logged
Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: GTK+ 2.10.14
« Reply #4 on: September 12, 2007, 12:23:58 am »

Quote
Could someone build it for VL 5.9? I think 5.9 should have all the gtk apps built against the latest version of gtk anyway.
Heck no! IMO 5.9 should come with the default slack package, which is 2.10.13. This because slack packages of gtk are very good, and to make sure slack packages that need gtk will work on VL.
Logged
Most music on my soundcloud page was arranged in programs running on VL.

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: GTK+ 2.10.14
« Reply #5 on: September 12, 2007, 02:01:30 am »

gimp 2,4 can be built on gtk 2.10.13, which is on the pseudo vec (5.9). I am running 2.4rc1 and its rock stable. I can send you a package of it if you want to. :P
Logged
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/

Dweeberkitty

  • Packager
  • Vectorian
  • ****
  • Posts: 836
    • Multimedia Bonus Disc
Re: GTK+ 2.10.14
« Reply #6 on: September 12, 2007, 07:50:29 am »

gimp 2,4 can be built on gtk 2.10.13, which is on the pseudo vec (5.9). I am running 2.4rc1 and its rock stable. I can send you a package of it if you want to. :P

No that's fine, thanks though. I guess I didn't see that VL5.9 had the latest. Thanks!
Logged
Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/