Please support VectorLinux!

Author Topic: CUPS - printer ready but no action  (Read 3587 times)

foxinsocks

  • Member
  • *
  • Posts: 5
CUPS - printer ready but no action
« on: September 11, 2007, 11:29:00 pm »
Running VL 5.8 std-RC1 on Dell Latitude CPx H laptop.
I've installed the driver and CUPS wrapper for my Brother HL-2040 laser printer and configured CUPS through VASM. Both "Print a Test Page' and printing from an application produce the following response from the printer: it gets all excited - the lights flash appropriately, the insides start to whir... and then, nothing  ???
Same happens whether I run as user or root.
In CUPS I set the Printer as Brother and the Model as either DCP-1200 or HL-1250, for reasons about to be explained. (The HL-2040 does not appear on the CUPS printer list but the DCP-1200 and the HL-1250 do.)

Now, it just so happens that I have a working setup on my desktop box (running FC5) for this printer, installed using the FC5 printer manager. Both the FC5 printer manager and CUPS give the same information - in slightly differing formats: Brother DCP-1200 Foomatic/hl1250 (recommended). I Understand this as saying "we're treating this printer as a Brother DCP-1200 using the recommended driver (hl1250)'.

It works a treat, but how do I translate that to my VL 5.8 laptop? I can set the printer as DCP-1200 or HL-1250 but I can't see how I can get CUPS on VL 5.8 to think in terms of DCP-1200 using a driver designated as HL-1250. Any help would be greatly appreciated. 

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: CUPS - printer ready but no action
« Reply #1 on: September 12, 2007, 08:12:28 am »
http://openprinting.org/show_printer.cgi?recnum=Brother-HL-2040

Did you try the HL-2060 driver? See info at the website above. It is in my CUPS drop-down Brother printer drivers list on VL SOHO 5.8...
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

foxinsocks

  • Member
  • *
  • Posts: 5
Re: CUPS - printer ready but no action
« Reply #2 on: September 12, 2007, 02:04:47 pm »
Thanks for the help.
No, I hadn't tried HL-2060. However, following your suggestion I did, with no better result. Then I went to the link you provided. After reading stuff there and on related pages at linuxprinting.org I downloaded the .ppd file recommended and installed it. CUPS "Print Test Page" worked! OpenOffice.org prints! GIMP prints!
Again, thank you for the helpful suggestion and link  :)

foxinsocks

  • Member
  • *
  • Posts: 5
Re: CUPS - printer ready but no action
« Reply #3 on: September 12, 2007, 04:10:56 pm »
I also meant to include in my earlier reply that I suspect that this solution is how FC5/CUPS installs the printer on my desktop box.

no2thesame

  • Packager
  • Vectorite
  • ****
  • Posts: 136
Re: CUPS - printer ready but no action
« Reply #4 on: September 19, 2007, 05:23:40 am »
No, I hadn't tried HL-2060. However, following your suggestion I did, with no better result. Then I went to the link you provided. After reading stuff there and on related pages at linuxprinting.org I downloaded the .ppd file recommended and installed it. CUPS "Print Test Page" worked! OpenOffice.org prints! GIMP prints!
Again, thank you for the helpful suggestion and link  :)

http://www.vectorlinux.com/forum2/index.php?topic=1594.0

There is a Vector How-To for setting up the Brother HL-2040 because I struggled with the same problem. (Got success the same way too!)
« Last Edit: September 19, 2007, 05:26:38 am by no2thesame »