VectorLinux
August 20, 2014, 12:06:59 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Had to use IP address to get CUPS to print to Windows Shared Printer  (Read 3688 times)
larkl
Member
*
Posts: 30


« on: September 12, 2007, 05:05:01 am »

 ???After a few hours of piddling with it, got my VL 5.8 Std box to print to my XP Pro printer. Had to use the IP address, not the NetBIOS name. 
Code:
smb://user%passwd/192.168.1.1/printer
Found some posts on the internet that indicated that this might work.  Seems odd since I've done this before with other distros (probably an older samba realease also) and it worked with the NetBIOS name.  I figured out that I couldn't see the shares with smbclient unless I passed the ip address.  Thought it was a windows firewall issue, but I guess not.  Since I use dynamic IP's, this is really a good solution. 
Logged
larkl
Member
*
Posts: 30


« Reply #1 on: September 12, 2007, 05:42:27 am »

Added the IP address of the windows box to /etc/hosts and now I can use the NetBIOS name.  Of course, if the windows box gets a different IP address, I'm screwed.  BTW - The WINS server option IS turned on in my Samba. 
Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #2 on: September 13, 2007, 01:34:36 am »

It's actually a problem with the firewall configuration. You can either disable the VL firewall OR edit /etc/rc.d/init.d/firewall
You should find this line:
Quote
PERMIT="192.168.0.0/24 445/tcp 137-139/tcp 445/udp 137-139/udp"
and change it to:
Quote
PERMIT="192.168.1.0/24 445/tcp 137-139/tcp 445/udp 137-139/udp"
I'm assuming your network is 192.168.1.* based on what you posted earlier. You should also remove the entry in the /etc/hosts file, but I think you already know that.
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
bigpaws
Vectorian
****
Posts: 1845


« Reply #3 on: September 13, 2007, 05:18:08 am »

stoichyu

This person is sending packets out not in no need for firewall changes.

Bigpaws
Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #4 on: September 13, 2007, 06:21:42 am »

stoichyu

This person is sending packets out not in no need for firewall changes.

Bigpaws

But Netbios name resolution requires that you are able to receive packets since you are querying the address of the said computer. This is what I did to get samba to use netbios resolution properly.
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
larkl
Member
*
Posts: 30


« Reply #5 on: September 13, 2007, 02:08:49 pm »

Thanks, stoichu. 

It was the firewall.  Just been using this distro for a few days and hadn't realized I had one (duh!).  Your mod fixed it, thanks.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!