VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Installing s/w on Xfce environment  (Read 3340 times)

jestinjoy

  • Member
  • *
  • Posts: 6
Installing s/w on Xfce environment
« on: September 14, 2007, 10:35:13 am »

When  i tried to install a torrent(tar.gz) s/w on vector linux basic distro(XFCE environ)..........
When ./configure command is executed it gave the error message..kde-apps not working......

I want to know how to install softwres on XFC environment..............
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Installing s/w on Xfce environment
« Reply #1 on: September 14, 2007, 11:22:56 am »

I sounds as though you were trying to compile/configure an application that requires more KDE libs than is provided on the VL58Standard installation.  If you don't mind me asking, what package are you trying to compile?
Logged

jestinjoy

  • Member
  • *
  • Posts: 6
Re: Installing s/w on Xfce environmentproblem
« Reply #2 on: September 14, 2007, 06:15:18 pm »

I was rying to install ktorrent on linux. when compiled it gave the error message that kde-app error.
check wheteher kde installed properly.........
I am using XFC environ......
Please help.I am new to vector.please help me in installing ktorrent........
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3276
Re: Installing s/w on Xfce environment
« Reply #3 on: September 14, 2007, 07:09:49 pm »

you just need to enable the testing extra and patches repositories. After that you should be able to install it using gslapt without buy problems. It will install all needed dependancies too

jestinjoy

  • Member
  • *
  • Posts: 6
Re: Installing s/w on Xfce environment
« Reply #4 on: September 16, 2007, 11:15:42 am »

Thanks ............

 I installed it1

But how can i access it. It is not shown under network menu!
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Installing s/w on Xfce environment
« Reply #5 on: September 16, 2007, 12:10:58 pm »

You should be able to start it from the terminal by typing 'ktorrent <enter>'.

Getting the correct ktorrent.desktop file into /usr/share/applications should fix the xfce/Network menu issue, but I'm not exactly sure where the current ktorrent.desktop file is located.  You could try a 'locate' to find the file, however you may want to update your system database with 'updatedb'.
Code: [Select]
# updatedb
# locate ktorrent.desktop

If you find that you already have a ktorrent.desktop file located in /usr/share/applications then the file probably needs to be edited to better fit XFCE.  If you post the output from the locate command posted above plus the output from the following comment I'm sure we can help you get all fixed up; command 'cat /path/to/ktorrent.desktop' (/path/to/ should be replaced with the correct path as output by the locate command).

Hope this helps!
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3276
Re: Installing s/w on Xfce environment
« Reply #6 on: September 17, 2007, 04:32:12 am »

open a terminal session and type ktorrent &

blackbelt_jones

  • Member
  • *
  • Posts: 56
Re: Installing s/w on Xfce environment
« Reply #7 on: September 17, 2007, 12:13:12 pm »

You can also use the "Run Command" dialogue box (1.) from the menu, or you can add the "Run command" applet (2.)to your panel like I have.


Here's a labelled screenshot

http://img222.imageshack.us/img222/8407/runcommandmv2.png

The nice thing about these options is that they don't leave another terminal window to clutter up your desktop.  You may find, as I have that using the applet or the run command dialogue from a keyboard shortcut that I set up (whole nother topic) is faster than searching through the menu or even pointing and clicking on an icon to run a favorite application.
« Last Edit: September 17, 2007, 12:34:29 pm by blackbelt_jones »
Logged