VectorLinux
September 17, 2014, 09:12:57 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Net connection problem  (Read 1733 times)
varaahan
Member
*
Posts: 52


« on: September 18, 2007, 07:43:47 am »

I am using pppoe-start for net connection .
This command does not work when initiated by an ordinary user though x permission has been given .

ls -l reveals this:
root:# ls -l /usr/sbin/pppoe-start
-rwxr-xr-x 1 root root 5607 2007-09-16 20:24 /usr/sbin/pppoe-start*

When invoked by user , it gives command not found error.

vector:/~
sridhar:$ pppoe-start
-bash: pppoe-start: command not found

And I tried to install tkpppoe and it is not working either.

May I know how to make this command executable by all ?

Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #1 on: September 18, 2007, 07:57:58 am »

As user, you can type "/usr/sbin/pppoe-start"
OR
Add /usr/sbin to your path.
OR
Make a symlink in /usr/bin to /usr/sbin/pppoe-start
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
newt
Vectorian
****
Posts: 1132



« Reply #2 on: September 18, 2007, 09:31:45 am »

Make a symlink in /usr/bin to /usr/sbin/pppoe-start

FWIW, I like stoichyu's last idea best:
In terminal as root, type
Code:
ln -s /usr/sbin/pppoe-start /usr/bin/pppoe-start
Logged
bigpaws
Vectorian
****
Posts: 1850


« Reply #3 on: September 18, 2007, 07:03:14 pm »

To make this command useable by users, change the
the users group.

As root in the console "chgrp users /usr/sbin/pppoe-start"
do not use the quotes.

When as root you used pppoe-setup there is an option for
dial on demand (connect on demand) which if called will
automatically call the command.

Bigpaws
Logged
varaahan
Member
*
Posts: 52


« Reply #4 on: September 19, 2007, 04:39:48 am »

To make this command useable by users, change the
the users group.

As root in the console "chgrp users /usr/sbin/pppoe-start"
do not use the quotes.

Bigpaws

But that didn't work out.

vector:/~
sridhar:$ /usr/sbin/pppoe-start
pppoe-start: You must be root to run this script


Make a symlink in /usr/bin to /usr/sbin/pppoe-start

FWIW, I like stoichyu's last idea best:
In terminal as root, type
Code:

ln -s /usr/sbin/pppoe-start /usr/bin/pppoe-start

And this too failed:


Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #5 on: September 19, 2007, 05:02:11 am »

Well, like it says "You must be root to run this script." So you have to be root to run it. If you just want to autoconnect at computer startup, you can append "/usr/sbin/pppoe-start" to /etc/rc.d/rc.local

If you really want to run it as user, try to run "sudo /usr/sbin/pppoe-start" If it is already configured, you're good to go, otherwise you have to get it into your /etc/sudoers file.
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!