VectorLinux
October 01, 2014, 08:10:07 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Default Network Connection  (Read 1263 times)
Ralph_Ellis
Member
*
Posts: 27


« on: September 13, 2007, 02:09:54 pm »

Hi,
I am running Vector Linux 5.8 SOHO on a Gateway laptop with a wireless card and a plug in ethernet connection. The internet connection that I want to use is the ethernet connection and that is set up and working properly. When I reboot the system, Vector Linux sometimes detects the wireless card and even though there are no active wireless networks in my area, the system tries to use the wireless connection as the default internet connection. I have worked around this by deleting the wireless connection and reinstalling the ethernet connection parameters. Is there any way to permanently disable the wireless connection, short of removing the card or forcing Vector Linux to use the ethernet connection as a default?
Thanks for your help
Ralph Ellis
ralphellis1@netscape.ca
Logged
Freston
Vectorite
***
Posts: 165


« Reply #1 on: September 13, 2007, 02:25:54 pm »

I'm new here myself. But the board seems welcoming enough :-D

This may do the trick
Code:
chmod -x /etc/rc.d/rc.wireless
Unless you want something fancyful.
Logged
newt
Vectorian
****
Posts: 1132



« Reply #2 on: September 13, 2007, 02:59:10 pm »

Another possibility is that the two nics are switching between restarts (i.e. eth0 and eth1 are switching devices between restarts).  There is a how-to the describes fixing an issue like this: http://www.vectorlinux.com/forum2/index.php?topic=979.0

HTH
Logged
saulgoode
Vectorite
***
Posts: 340



« Reply #3 on: September 13, 2007, 04:21:00 pm »

I was thinking you could blacklist the wireless driver module in '/etc/modules.d/blacklist'.

Logged

A complex system that works is invariably found to have evolved from a simple system that works.
Ralph_Ellis
Member
*
Posts: 27


« Reply #4 on: September 17, 2007, 10:06:25 am »

I believe that Vector Linux was switching back and forth between using eth0 for wireless and wired connections.  Since I was not using the wireless for anything, I actually opened up the laptop and disconnected the wireless card. Even in Wndows, it was always a difficult pig of a card.
When in doubt, use brute force.
Thanks for the suggestions.
Ralph Ellis
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!