April 17, 2015, 10:56:13 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: pkgtools-tukaani  (Read 1064 times)
Posts: 1321

« on: September 21, 2007, 10:56:12 pm »


I needed more space for VL which I had installed in my trial partition. So I decided to move VL to the partition of slackware which is larger and at the same time I enlarged my home partition for VL. The transfer went w/o a hitch and VL runs now in its new larger partition.

I then made a new install for slackware-11 and when completed I decided to upgrade to sw-12.0 using slackpkg. That took a while and when completed the job was badly done. slackware/x was not installed and the X11/R6 directory was moved to /X11/R6.back. The only window manager I could open were blackbox and wmaker. Kde and fluxbox complained about lack of some libs and cups could not be started again no libs.

When I tried to start slackpkg again it would not open saying it could not find gawk yet it was there. I removed slackpkg and gawk and installed them again, it did not help.

Back into VL I found pkgtools-tukaani_1.2.4. I installed it in sw and was really pleased on what this program offers and can do. With it I could install/upgrade /slackware/x and ../lib after which all window managers and cups run well in slackware-12.

Now I tried pkgtools-tukaani in VL and it works just great giving it access to the VL
repositories. Gslapt is surely a nice program, however, IMO pkgtools-tukaani offers more and is so easy to use. May be it is since I am a bid GUI challenged coming from a long DOS background.

One thing strange so in slackware-12, as well as in the latest slax and absolute-linux distros when trying to logout from a window maker I get a blank screen with only the pointer arrow showing and if I do not reboot fast with ctrl-alt-del the keyboard and may be more freezes. To avoid this I have to go to ctrl-alt-F2, halt or reboot from there or kill the window maker if I want to change to another one. Ctrl-alt-backspace does the same, that is will not kill X instead leads to freezing.

I wonder if others have this problem with the latest slackware.

Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!