VectorLinux
November 28, 2014, 05:12:04 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Getting Orage to start with Sunday, not Monday  (Read 5386 times)
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« on: September 22, 2007, 06:36:49 pm »

Orage starts the week on Monday. I want it to start on Sunday.

Someone told me how to do this, but the message was lost when the forum was reorganized. I remember that it involved setting locale to Great Britain or something like that.

Does anyone know how to do this? (Of course someone does!<g>) This time I'll be sure to copy the directions to my Tuxcards file.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #1 on: September 22, 2007, 07:10:51 pm »

http://bbs.archlinux.org/viewtopic.php?pid=282475
 Smiley
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #2 on: September 22, 2007, 08:49:09 pm »

The suggestions in the ArchLinux link didn't work. However, I read a bit and flailed about and I *think* I may have solved it.

I closed down X and as user typed these at a prompt:
LANG=en_GB
LC_ALL=en_GB

When I restarted X and ran Orage, the calendar started on Sunday. Yay! Then I added the lines to /etc/rc.d/rc.local in hopes the change will persist after a reboot (which I haven't tried yet).

I have a vague memory of doing exactly this when I changed it successfully months ago (following a suggestion on this forum, now unfortunately lost). It seems weird that you have to change to en_GB, but with en_US Orage starts the calendar week with Monday, which messes with my brain.<g>
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #3 on: September 22, 2007, 09:09:54 pm »

I think I posted the fix for you before, but it amazes me that it didn't find it's way to your famous Tuxcards file... Shocked
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #4 on: September 23, 2007, 07:25:51 am »

I'm currently using VL5.9 and Orage shows Sunday as first day of week.  So for the heck of it I compared VL5.9's en_US locale file with the one in VL5.8.

I found this interesting difference.

(VL5.9)
Quote
LC_CTYPE
copy "en_GB"
END LC_CTYPE

(VL5.Cool
Quote
LC_CTYPE
copy "i18n"
END LC_CTYPE

I'd bet if you made the swap you would be in good shape, without having to use the en_GB locale and messing up important things like paper type, currency etc.
Logged
Tigerwolf
Vectorite
***
Posts: 152



« Reply #5 on: September 30, 2007, 06:48:04 pm »

The suggestions in the ArchLinux link didn't work. However, I read a bit and flailed about and I *think* I may have solved it.
...
LANG=en_GB
LC_ALL=en_GB

The problem with this is that it will force *everything* to comply with GB/UK settings.  If you run 'locale' you'll see things like money, paper sizes, etc. are all changed and something would eventually bite back in some other app.

Additionally, some things I've read indicate that the GB time/day definitions are actually *wrong* because UK  calendars mostly should start with Monday as the first weekday.   The 'wrongness' just makes it correct for the US.

I found (what I think is) a better way.

The file    /etc/profile.d/lang.sh    sets the slackware default locale to en_US.   I added a line under the existing export statement to make it read:

export LANG=en_US
export LC_TIME=en_GB

This changes only the TIME definitions to the (wrong?) GB values without messing with any of the other locale values.

At least it fixed orage.

I've read enough conflicting stuff on this that it makes my head asplode.

I *think* the text locale values in /usr/share/i18n/  get compiled into binary files that end up in /usr/lib/locale entries.   That's why editing /usr/share/i18n/ entries don't work (at least not for me).   It also appears to be a rather arcane process to compile the binary *and* apparently X uses some similar yet different locale scheme.

Hopefully this mess will get sorted out by those that actually know what's stored where and what the proper values should be.   When that happens, removing the LC_TIME=en_GB entry above would be necessary.

 
Logged

=^_^=  Tigerwolf

Running: Vector Linux 5.8 Standard   12-16-2006
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #6 on: September 30, 2007, 10:39:30 pm »

Thanks. I will try this at my earliest opportunity.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!