VectorLinux
April 18, 2014, 02:39:10 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Need help with Lilo[SOLVED]  (Read 1179 times)
dnr
Member
*
Posts: 3


« on: September 24, 2007, 02:36:00 am »

I'm running VL 5.8 Standard and I installed it to my hdd using the vlliveinstall command with vl user. Problem is when I try to install Lilo it keeps giving me an error of "cannot find vmlinuz", Im running Live-CD so can't do much about that with my knowledge of linux. Anyhelp would be nice. So right now even though its installed, I have to use the Live-CD...
« Last Edit: September 24, 2007, 09:01:23 pm by dnr » Logged
nightflier
Administrator
Vectorian
*****
Posts: 3939



« Reply #1 on: September 24, 2007, 03:52:18 am »

You could try installing from the regular (not live) version. It has a more robust installer.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #2 on: September 24, 2007, 07:24:30 am »

dnr,
first make sure there is a vmlinuz in your /boot dir on the new install.
then in a terminal you need to mount your /dev and /proc dirs like this (assuming your HD partition is mounted at /mnt/hda1)
Code:
mount -o bind /dev/ /mnt/hda1/dev
mount -o bind /proc /mnt/hda1/proc
then you need to chroot to the HD and run lilo like this
Code:
chroot /mnt/hda1
lilo

Let us know if that helps,
Uelsk8s
Logged
dnr
Member
*
Posts: 3


« Reply #3 on: September 24, 2007, 09:01:50 pm »

Yep, works great, thanks for the advice. I love the speed ooooohhh yeah, hate the boot times though
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!